poj 2629 Common permutation

Common permutation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5059 Accepted: 1519

Description

Given two strings of lowercase letters, a and b, print the longest string x of lowercase letters such that there is a permutation of x that is a subsequence of a and there is a permutation of x that is a subsequence of b.

Input

Input consists of pairs of lines. The first line of a pair contains a and the second contains b. Each string is on a separate line and consists of at most 1,000 lowercase letters.

Output

For each subsequent pair of input lines, output a line containing x. If several x satisfy the criteria above, choose the first one in alphabetical order.

Sample Input

pretty
women
walking
down
the
street

Sample Output

e
nw
et
#include<iostream>
#include<algorithm>
using namespace std;

int comp(char &a,char &b)
{
return a<b;
}

int main()
{
char a[1001];
char b[1001];
int i,j;
int lena,lenb;
int pos;
while(gets(a) && gets(b))
{
lena=strlen(a);
lenb=strlen(b);
sort(a,a+lena,comp);
sort(b,b+lenb,comp);
pos=-1;
for(i=0;i<lena;i++)
{
for(j=pos+1;j<lenb;j++)
{
if(a[i]==b[j])
{
pos=j;
cout<<a[i];
break;
}
}
}
cout<<endl;
}
return 0;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258621.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值