HDU1013

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39679    Accepted Submission(s): 12201


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.

Sample Input
  
  
24 39 0

Sample Output
  
  
6 3

Source
 
自己的代码(WA----超时):
#include<stdio.h>
#include<iostream>
#include<string.h>
#define maxn 100000
using namespace std;
char s[maxn];
int main()
{
    memset(s,0,sizeof(s));
    while(scanf("%s",&s)&&s!="0")
    {
        int dgt=0;
        int len=strlen(s);
        for(int i=0;i<len;i++)
        {
            dgt+=(s[i]-'0');
        }
        //cout<<dgt<<endl;
        int rt=0;
        int ans;
         while(dgt)
        {
            rt+=dgt%10;
            dgt=dgt/10;
            if(!dgt)
            {
                 ans=rt;
                 dgt=rt;
                 rt=0;
                 if(ans<10) break;
            }

        }
        printf("%d\n",ans);

    }


}

这题测试数据可能会很长,所以不能简单的用传统方法

考虑用处理字符串的方式来进行,但开数组也没完没了的,所以就直接对每一个字符来处理

即,每得到一个字符马上加到 sum 上去(sum是结果),如果sum大于9了,马上对sum进行处理,个位和十位相加令其变为一个数(结果一样)

代码如下:

这题测试数据可能会很长,所以不能简单的用传统方法

考虑用处理字符串的方式来进行,但开数组也没完没了的,所以就直接对每一个字符来处理

即,每得到一个字符马上加到 sum 上去(sum是结果),如果sum大于9了,马上对sum进行处理,个位和十位相加令其变为一个数(结果一样)

代码如下:

 
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    char c;
    int sum=0;
    while(c=getchar())
    {
        if(c=='\n')
        {
            cout<<sum<<endl;
            c=getchar();
            if(c=='0') break;
            else sum=c-'0';
            continue;
        }
        sum+=c-'0';
        if(sum>9)//只需处理一次即可,因为对sum处理的及时,所以sum不可能大于18   
        {
            sum=sum%10+sum/10;
        }

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值