poj 2485 (百练) Highways

基础prim算法,一定做熟了。


Highways

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
输入
The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
输出
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
样例输入
1

3
0 990 692
990 0 179
692 179 0
样例输出
692
提示
Huge input,scanf is recommended.
来源
POJ Contest,Author:Mathematica@ZSU

接着上代码:
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
#define INF 100000000


int road[505][505];
int set[505];
int d[505], n;


void prim()
{
int i, j, min, tag;
memset(d, 0x3f, sizeof(d));
//d[1] = 0;
int max = -1;
set[1] = 1;

for(i = 1; i <= n; i ++)
d[i] = road[i][1];

for(j = 0; j < n - 1; j ++)
{
min = INF;
for(i = 1; i <= n; i ++) //find the shortest one
{
if(!set[i] && d[i] < min) //not in set[]
{
min = d[i];
tag = i;
}
}
set[tag] = 1;
for(i = 1; i <= n; i ++)
{
if(!set[i] && road[i][tag] < d[i])
d[i] = road[i][tag];
}
}
for(i = 1; i <= n; i ++)
{
if(max < d[i])
max = d[i];
}
printf("%d\n", max);
}


int main()
{
int T, i, j, w;
scanf("%d", &T);
while(T --)
{
memset(set, 0, sizeof(set));
memset(road, 0x3f, sizeof(road));
scanf("%d", &n);
for(i = 1; i <= n; i ++)
{
for(j = 1; j <= n; j ++)
{
scanf("%d", &w);
if(road[i][j] > w)
road[i][j] = w;
}
}
prim();
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值