Highways (最小生成数)


    The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

    Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

    The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
    The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

    The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

    The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
    Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

    If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input

    9
    1 5
    0 0
    3 2
    4 5
    5 1
    0 4
    5 2
    1 2
    5 3
    3
    1 3
    9 7
    1 2

Sample Output

    1 6
    3 7
    4 9
    5 7
    8 3


题意: 给出n个点的坐标,每个坐标表示一座房子,再给出m条路,表示从编号为a的房子到编号为b的房子已经是连通的,点之间的距离就是房子的距离,求连通所有房子的最小生成树,输出直接连通的房子的编号,输出顺序没要求。

分析: 在找最小生成数的时候不是很麻烦,题目让输出的是直接相通的房子编号,这里我是定义了一个新的数组num[],用来存放直接相通的房子编号,在更新最短距离的时候(也就是在找最小生成树的时候)我把被选中的两个直接相连的房子存放在num[]中,最后更新完,用个循环输出num[]数组即可。可能我表达的不是很清楚,那就自己理解理解,实在不行,看代码理解!

#include<stdio.h>
#include<math.h>
int m,n,book[755],num[755];
double e[755][755],dis[755];
double inf = 99999999.0;
void Prim()
{
	int i,j,k;
	double min;
	for(i = 1; i <= n; i ++)
	{
		dis[i] = e[1][i];
		book[i] = 0;
		num[i] = 1;
	}	
	dis[1] = 0;
	book[1] = 1;
	for(i = 1; i < n; i ++)
	{
		min = inf;
		for(j = 1; j <= n; j ++)
			if(book[j] == 0 && dis[j] < min)
			{
				min = dis[j];
				k = j;
			}
		book[k] = 1;
		for(j = 1; j <= n; j ++)
			if(book[j] == 0 && dis[j] > e[k][j])
			{
				dis[j] = e[k][j];
				num[j] = k;
			}
	}
	for(i = 1; i <= n; i ++)
		if(dis[i] != 0)
			printf("%d %d\n",i,num[i]);
}
int main()
{
	int i,j,t1,t2;
	double x[755],y[755];
	while(scanf("%d",&n) != EOF)
	{
		for(i = 1; i <= n; i ++)
			for(j = 1; j <= n; j ++)
				if(i == j)
					e[i][j] = 0.0;
				else
					e[i][j] = inf;
		for(i = 1; i <= n; i ++)
		{
			scanf("%lf%lf",&x[i],&y[i]);
			for(j = 1; j <= n; j ++)
				e[i][j] = e[j][i] = sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
		}	
		scanf("%d",&m);
		for(i = 1; i <= m; i ++)
		{
			scanf("%d%d",&t1,&t2);
			e[t1][t2] = e[t2][t1] = 0;
		}	
		Prim();
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值