csu 1067 1vs1

1067: 1 VS 1

Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 31 Solved: 24
[Submit][Status][Web Board]

Description

Alice and Bob are playing the game SanguoSha 1VS1.If Alice take a card or use a card (it may be slash,missed,peach,duel,sabotage or theft and so on) or discard (sometimes he does not need to throw any card) we will write down an uppercase 'A', if Bob does this, of course, we will write down the letter "B'. Tell me the length of the longest operation combo performed by either player.

Input

There are several test cases, each test case contains only a string composed of uppercaser 'A' and 'B'.The input will finish with the end of file.The length of the string is no more than 1000.

Output

. For each the case, output an integer indicate for the length.

Sample Input

AAABBAAAAA
AABBBBAA
AAAAAAAA

Sample Output

5
4
8

HINT

Source

[Submit][Status][Web Board]

题目思路:
                  先遍历字符串,将遍历过程中得到的相同字母的最大长度保存在一个变量里,最后输出。

代码如下:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>


int main()
{
    char a[1005];
    int i;


    while (scanf ("%s",&a)!=EOF)
    {
        int L;
        int MAX;
        int count;
        L=strlen(a);
        a[L]='0';
        MAX=0;
        count=0;
        for (i=0;i<L;i++)
        {
            if (a[i+1]==a[i])
            {
                count++;
            }
            else
            {
                count++;
                if (count>MAX)
                {
                    MAX=count;
                    count=0;
                }
                else
                {
                    count=0;
                }
            }
        }
        printf ("%d\n",MAX);
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值