Uva 101:The Blocks Problem(木块问题)

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block b i adjacent to block b i+1 for all $0 \leq i < n-1$ as shown in the diagram below:
 
\begin{figure}\centering\setlength{\unitlength}{0.0125in} %\begin{picture}(2......raisebox{0pt}[0pt][0pt]{$\bullet\bullet \bullet$ }}}\end{picture}\end{figure}
Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto blockb after returning any blocks that are stacked on top of blocks a andb to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing blockb, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of blocka, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above blocka retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of blocka, and any blocks that are stacked above block a, onto the top of the stack containing blockb. The blocks stacked above block a retain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input 

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n <25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until thequit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numberedi ( $0 \leq i < n$ wheren is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output wheren is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:

题目大意:

输入n,得到编号为0~n-1的木块,摆放在顺序排列编号为0~n-1的位置。现对这些木块进行操作,操作分为四种。

1、move a onto b:把木块a、b上的木块放回各自的原位,再把a放到b上;

2、move a over b:把a上的木块放回各自的原位,再把a发到含b的堆上;

3、pile a onto b:把b上的木块放回各自的原位,再把a连同a上的木块移到b上;

4、pile a over b:把a连同a上木块移到含b的堆上。

思考:       

与Uva 127类似的模拟题,考虑用一个25*25的数组存储,并且用一个top数组存各栈的顶端。由于需要频繁地执行“放回原位这个步骤”(同理找位置也可以写成一个函数find),可以写一个clear函数执行。由于没有任何一步可以把木块放到空的位置,随意放回原位不需要考虑原位还有其他木块这种情况。

代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
const int MAXN=25;
int q[25][25];//木块存储
int top[25];//记录顶端
char s1[5],s2[5];//用来保存命令
int b1,b2;
void find(int *a,int *b,int c,int m)//找到木块c的位置
{
	for(int i=0;i<m;i++)
	{
		for(int j=0;j<top[i];j++)
		if(q[i][j]==c)
		{
			*a=i;
			*b=j;
			return;
		}
	}
}
void clear(int a,int b)//清空(a,b)上面的木块
{
	for(int i=b+1;i<top[a];i++)
	{
		q[q[a][i]][0]=q[a][i];
		top[q[a][i]]++;
	}
	top[a]=b+1;
}
//接下来都是纯粹的模拟了
int main()
{
	int n;
	scanf("%d",&n);
	memset(top,0,sizeof(0));
	for(int i=0;i<n;i++)
	{
		q[i][0]=i;
		top[i]++;
	}
	for(;;)	
	{
	        scanf("%s",s1);
		if(!strcmp(s1,"quit"))
			break;
		scanf("%d",&b1);
		scanf("%s",s2);
		scanf("%d",&b2);
		if(b1==b2)
			continue;
		int x1,y1,x2,y2;
		find(&x1,&y1,b1,n);
		find(&x2,&y2,b2,n);
		int temp;
		temp=q[x1][y1];
		if(x1==x2)
			continue;
		if(!strcmp(s1,"move")&&!strcmp(s2,"onto"))
		{
			clear(x1,y1);
			clear(x2,y2);
			q[x2][y2+1] =temp;
			top[x1]--;
			top[x2]++;
		}
		if(!strcmp(s1,"move")&&!strcmp(s2,"over"))
		{
			clear(x1,y1);
			q[x2][top[x2]]=temp;
			top[x2]++;
			top[x1]--;
		}
		if(!strcmp(s1,"pile")&&!strcmp(s2,"onto"))
		{
			int d=top[x1]-y1;
			clear(x2,y2);
			top[x2]=y2+d+1;
			for(int i=0;i<d;i++)
			{
				q[x2][y2+i+1]=q[x1][y1+i];
			}
			top[x1]=y1;
		}
		if(!strcmp(s1,"pile")&&!strcmp(s2,"over"))
		{
			for(int i=y1;i<top[x1];i++)
			{
				q[x2][top[x2]]=q[x1][i];
				top[x2]++;
			}
			top[x1]=y1;
		}
	}
	for(int i=0;i<n;i++)
	{
		printf("%d:",i);
		for(int j=0;j<top[i];j++)
		{
			printf(" %d",q[i][j]);
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值