uva101

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all $0 \leq i < n-1$ as shown in the diagram below:
 
\begin{figure}\centering\setlength{\unitlength}{0.0125in} %\begin{picture}(2......raisebox{0pt}[0pt][0pt]{$\bullet\bullet \bullet$ }}}\end{picture}\end{figure}
Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto blockb. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input 

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until thequit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i ( $0 \leq i < n$ where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:


思路:用三个整型数组将它们的序号和堆里所包含的数字还有数字的个数记录下来,发现有move操作的都应先将B上元素移动开,有onto操作的都应先将A上元素移动开。之后进行的都是A向B移动的操作。移动一个A也是移动 移动A及A以上也是移动所以只需写一个移动的函数就可以了。。WA了一次 误以为a一直都是最底下的一个 没想到它也可以被移动到别的堆里去。。

#include <iostream>
using namespace std;
#include <string>

int index[25];//序号
int stack[25][25];//这一堆里面的数字
int num[25];//各个堆里面有几个数字
void move(int a)//把a上的元素还原
{
	int index1 = index[a], t; // num[index1]>0 WA a不一定是最底下一个。。
	while (stack[index1][num[index1]] != a)
	{
		t = stack[index1][num[index1]--];
		index[t] = t;
		stack[t][++num[t]] = t;
	}
}
void atob(int a,int b)
{
	int i = 0;
	int temp[25];
	for (i = 0; num[index[a]] >= 0;i++)
	{
		temp[i] = stack[index[a]][num[index[a]]--];//将a中元素逆序存放在临时数组中
		index[temp[i]] = index[b]; //将所有移动过来的元素的位置设置为b所在的堆的序号
	}
	i = i - 1;
	while (i >= 0)
		stack[index[b]][++num[index[b]]] = temp[i--];
}
int main()
{
	int n;
	int a, b;
	int i;	
	char mani[5],manip[5];
	while (cin >> n)
	{
		for (i = 0; i < n; i++)
		{
			index[i] = i; //标记每个数字所在位置
			stack[i][0] = i; //每个堆的首元素都是他们自己
			num[i] = 0;//堆里不包含他们自己的元素个数
		}
		while (cin >> mani && mani[0]!='q')
		{
			cin >> a >> manip >> b;
			if (index[a] == index[b])
				continue;
			if (mani[0] == 'm')
				move(a);
			if (manip[1] == 'n')
				move(b);
			atob(a, b);
		}
		for (i = 0; i < n; i++)
		{
			int k = 0;
			printf("%d:", i);
			while (k <= num[i])
				printf(" %d", stack[i][k++]);
			printf("\n");
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值