源码编译 g++ 4.1

    由于为了编译一个很早的软件,需要很低版本的g++,现在的Linux系统都不会默认安装这么低版本的g++编译器,软件源一般也不会提供这么低版本的编译器,所以只好用源码编译一个来用。
    我一开始在Ubuntu 14.04(32位)上编译,但很多错误解决不了,所以换了一个更低版本的系统 Ubuntu 9.10(32位)然后才编译成功。不过编译 g++ 4.1还有我的那个软件需要依赖很多其他软件,而由于软件源没有合适版本(用apt-get会提示依赖关系不满足),这一部分需要额外下载合适版本的源码编译安装,只要版本合适,一般不会遇到什么问题,所以这里就不涉及了。

具体步骤

  • 先下载源码http://ftp.gnu.org/gnu/gcc/gcc-4.1.2/,选择gcc-4.1.2.tar.bz2
  • 解压缩tar jxvf gcc-4.1.2.tar.bz2到当前文件夹
  • 进入 gcc-4.1.2,执行命令mkdir build; cd build
  • 然后执行命令../configure --enable-checking=release --enable-languages=c,c++ --disable-multilib
  • 最后就是makesudo make install

补充说明

  • 编译g++时,一般要给configure设置一些参数,而不是直接执行
  • 一些高版本的g++会提供脚本(contrib文件夹中)用于下载编译g++依赖的软件包,所以在解压源码后可以看看这个版本是否提供

参考资料
- https://blog.csdn.net/shaochat/article/details/44748267
- https://www.cnblogs.com/mengfanrong/p/4844808.html
- https://blog.csdn.net/rs_network/article/details/7687902
- https://www.cnblogs.com/oloroso/p/5984985.html
- https://www.cnblogs.com/ezhang/p/3853581.html

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u011008379/article/details/79849903
文章标签: g++ 源码编译
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭