poj 2923 Relocation(状态压缩dp+背包)

Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1479 Accepted: 597

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3
 

题意:

    两个车有容量a与b,n个物品,每个物品有一个体积,问最小多少次能够运完他们。

感想:状态压缩真的很奇妙。。。
1.掌握位运算的运算法优先级别很重要 
2.掌握基本位运算  
  (1).判断是否为0  if((S&1<<i)==0) 
  (2).将第i位置1  S|1<<i
  (3).将第i位置0  S&~(1<<i)
3.要有状态的思想 每次是对状态进行操作 
 
 
思路:(状态压缩DP+背包)
n<=10,比较小,可以用状态压缩,先求出所有可以通过一次运送(两辆车)的组合情况,用1<<n的二进制数的每一位表示一件物品是否运送。
再从所有可以一次运送的组合中,用背包(?)求出最小次数。。。
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int INF = 1<<30;
int c1,c2,n,s,vis[1<<10],w[11],dp[1<<10],q[1<<10];

bool onego(int x)
{
    int i,j,sum=0;
    memset(vis,0,sizeof(vis));
    vis[0]=1;
    for(i=0;i<n;i++)
    {
        if(x&(1<<i))
        {
            sum+=w[i];
            for(j=c1-w[i];j>=0;j--)//j大于0就一定可以一次运送 那么j+w[i]也可以
                if(vis[j]) vis[j+w[i]]=1;
        }
    }
    for(i=c1;i>=0;i--)//判断加上第二辆辆车可以搞定
        if(sum-i<=c2&&vis[i]) return true;
    return false;
}


int main()
{
    int i,j,t,T,temp;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d%d%d",&n,&c1,&c2);
        if(c1>c2)
        {
            temp=c1;
            c1=c2;
            c2=temp;
        }
        for(i=0;i<n;i++)
            scanf("%d",w+i);
        for(s=0,i=0;i<(1<<n);i++)//用q[s]记录可以一次运送的组合种类数
            if(onego(i)) q[s++]=i;
        for(i=(1<<n)-1;i>0;i--) dp[i]=INF;
        dp[0]=0;
        for(i=0;i<s;i++)
        {
            for(j=(1<<n)-1-q[i];j>=0;j--)//背包思想
                if(!(j&q[i])) dp[j|q[i]]=min(dp[j|q[i]],dp[j]+1);//。。。??
        }
        printf("Scenario #%d:\n%d\n",t,dp[(1<<n)-1]);
        if(t!=T) printf("\n");
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值