Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 2952 | Accepted: 1031 |
Description
To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........
The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.
What is the maximum number of cows that can protect themselves while tanning given the available lotions?
Input
* Line 1: Two space-separated integers: C and L
* Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi
* Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri
Output
A single line with an integer that is the maximum number of cows that can be protected while tanning
Sample Input
3 2 3 10 2 5 1 5 6 2 4 1
Sample Output
2
Source
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstdio>
#include <queue>
#include <functional>
using namespace std;
typedef pair<int, int> P;
priority_queue<int, vector<int>, greater<int>> que;
P cow[2600], lot[2600];
int ans = 0;
int main()
{
int C, L, j = 0;
scanf("%d%d", &C, &L);
for(int i = 0; i < C; i++)
scanf("%d%d", &cow[i].first, &cow[i].second);
for(int i = 0; i < L; i++)
scanf("%d%d", &lot[i].first, &lot[i].second);
sort(cow, cow+C);
sort(lot, lot+L);
for(int i = 0; i < L; i++)
{
for(; j < C && cow[j].first <= lot[i].first; j++)
que.push(cow[j].second);
while(lot[i].second && que.size())
{
int maxspf = que.top(); que.pop();
if(maxspf >= lot[i].first)
{
ans++;
lot[i].second--;
}
}
}
printf("%d\n", ans);
}