POJ 3614 Sunscreen(优先队列)

25 篇文章 0 订阅
4 篇文章 0 订阅

Sunscreen
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8404 Accepted: 2973
Description

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they’re at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn’t tan at all……..

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

  • Line 1: Two space-separated integers: C and L
  • Lines 2..C+1: Line i describes cow i’s lotion requires with two integers: minSPFi and maxSPFi
  • Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1
Sample Output
2

题意:有C头奶牛日光浴,每头奶牛分别需要minSPF_i和maxSPF_i单位强度之间的阳光。现有L种防晒霜,分别能使阳光强度稳定为SPF_i,其瓶数为cover_i。求最多满足多少头奶牛

题解:将奶牛按照阳光强度的最小值从小到大排序。
将防晒霜也按照能固定的阳光强度从小到大排序
从最小的防晒霜枚举,将所有符合 最小值小于等于该防晒霜的 奶牛的 最大值 放入优先队列之中。
然后优先队列是小值先出

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;

const int maxn = 11110;
priority_queue<int,vector<int>,greater<int> >pq;
struct node
{
    int x,y;
    friend bool operator < (node a,node b)
    {
        return a.x < b.x;
    }
}cow[maxn],bot[maxn];

int main()
{
    int c,l;
    cin>>c>>l;
    for(int i=0;i<c;i++)
        cin>>cow[i].x>>cow[i].y;
    for(int i=0;i<l;i++)
        cin>>bot[i].x>>bot[i].y;
    sort(cow,cow+c);
    sort(bot,bot+l);
    int cur = 0,ans = 0;// 现在正等待涂防晒霜的奶牛的index
    for(int i=0;i<l;i++)
    {
        while(cur < c&&cow[cur].x <= bot[i].x)
        {
            pq.push(cow[cur].y);
            cur++;
        }
        while(!pq.empty()&&bot[i].y)
        {
            int maxSPF = pq.top();
            pq.pop();
            if(maxSPF >= bot[i].x)// “奶牛上限”比这一瓶的上限大,说明这头奶牛可以被涂上防晒霜
            {
                ans++;
                bot[i].y--;
            }// else 这头奶牛不能被涂上,因为bottle是按SPF排过序的,没有比这瓶更小的SPF了
        }
    }
    cout<<ans<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值