POJ 2996 Help Me with the Game 大模拟

Help Me with the Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2927 Accepted: 1900

Description

Your task is to read a picture of a chessboard position and print it in the chess notation.

Input

The input consists of an ASCII-art picture of a chessboard with chess pieces on positions described by the input. The pieces of the white player are shown in upper-case letters, while the black player's pieces are lower-case letters. The letters are one of "K" (King), "Q" (Queen), "R" (Rook), "B" (Bishop), "N" (Knight), or "P" (Pawn). The chessboard outline is made of plus ("+"), minus ("-"), and pipe ("|") characters. The black fields are filled with colons (":"), white fields with dots (".").

Output

The output consists of two lines. The first line consists of the string "White: ", followed by the description of positions of the pieces of the white player. The second line consists of the string "Black: ", followed by the description of positions of the pieces of the black player.

The description of the position of the pieces is a comma-separated list of terms describing the pieces of the appropriate player. The description of a piece consists of a single upper-case letter that denotes the type of the piece (except for pawns, for that this identifier is omitted). This letter is immediatelly followed by the position of the piece in the standard chess notation -- a lower-case letter between "a" and "h" that determines the column ("a" is the leftmost column in the input) and a single digit between 1 and 8 that determines the row (8 is the first row in the input).

The pieces in the description must appear in the following order: King("K"), Queens ("Q"), Rooks ("R"), Bishops ("B"), Knights ("N"), and pawns. Note that the numbers of pieces may differ from the initial position because of capturing the pieces and the promotions of pawns. In case two pieces of the same type appear in the input, the piece with the smaller row number must be described before the other one if the pieces are white, and the one with the larger row number must be described first if the pieces are black. If two pieces of the same type appear in the same row, the one with the smaller column letter must appear first.

Sample Input

+---+---+---+---+---+---+---+---+
|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
+---+---+---+---+---+---+---+---+
|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
+---+---+---+---+---+---+---+---+
|...|:::|.n.|:::|...|:::|...|:p:|
+---+---+---+---+---+---+---+---+
|:::|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|...|:::|...|:::|.P.|:::|...|:::|
+---+---+---+---+---+---+---+---+
|:P:|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
+---+---+---+---+---+---+---+---+
|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
+---+---+---+---+---+---+---+---+

Sample Output

White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6
 
对于这道题,其实不算难,还是要灰常细心,当然还是各种坑爹货,比如,数字是从下向上1到8的序列,并且此题建议用C风格的scanf控制输入格式,这样对于复杂读入处理简单,先打出简单的表,然后按照KQRBNP的顺序输出,这道题还有一个坑点就是白棋是字母优先输出,黑棋是数字优先输出,解决方法就是用不同的白旗和黑棋分别用不同的函数查找,白旗由下向上查找,黑气由上向下查找,查找到立刻输出,这样题目基本就AC了,需要细心的地方特别多,编的时候要注意。
 
下面是AC代码:
 
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
char chess[35][35],final[10][10];
char ch[40],ch1,ch2;
int flag;
void findw(char p)
{
	int i,j;
	for(j=8;j>0;j--)
		for(i=1;i<=8;i++)
		{
			if(final[j][i]==p)
			{
				if(flag==1)
					flag=0;
				else
					printf(",");
				if(p!='P')
					printf("%c",p);
				printf("%c%d",i-1+'a',9-j);
			}

		}
}
void findb(char p)
{
	int i,j;
	for(j=1;j<=8;j++)
		for(i=1;i<=8;i++)
		{
		if(final[j][i]==p)
		{
			if(flag==1)
				flag=0;
			else
				printf(",");
			if(p!='p')
				printf("%c",p-32);
			printf("%c%d",i-1+'a',9-j);
			}
		}
}
int main()
{
	int i,j,k;
	for(i=1;i<=8;i++)
	{
		scanf("%s",ch);
		scanf("%s",chess[i]);
	}
	scanf("%s",ch);
	for(i=1;i<=8;i++)
	{
		k=1;
		for(j=2;j<35;j+=4)
		{
			final[i][k]=chess[i][j];
			k++;
		}
	}
	flag=1;
	printf("White: ");
    findw('K');
    findw('Q');
    findw('R');
    findw('B');
    findw('N');
    findw('P');
	flag=1;
	printf("\nBlack: ");
	findb('k');
	findb('q');
	findb('r');
	findb('b');
	findb('n');
	findb('p');
	printf("\n");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值