ZOJ3829 ACM-ICPC 2014 亚洲区域赛牡丹江赛区现场赛K题 Known Notation 贪心

Known Notation

Time Limit: 2 Seconds       Memory Limit: 131072 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input
3
1*1
11*234**
*
Sample Output
1
0
2
    这道题是一个其实很简单,然后WA点很多的题目,注意便是极好的~~~,题目意思是给你一个式子,问你变成后缀表达式需要的最少步骤,题目解法就是很简单的,贪心,对于一个后缀表达式,必须满足符号数量小于数字数量,那么缺几个数字补几个,那么就是insert的主要步骤,然后,对于表达式,最后一位如果是数字,并且没有补充星号,则需要与前面星号交换位置,注意这些以后,就直接扫一遍,栈内初始化数量为之前步骤添加的数字数,没有添加就为0,数字就入栈入栈一个,符号就出栈一个,当数字数量少于2时了就交换后面的数字,然后计算交换和插入总数输出即可AC,具体AC代码如下:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<map>
#include<vector>
#include<queue>
using namespace std;
char ch[1005];
int main()
{
  //  freopen("in.txt","r",stdin);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>ch;
        int len=strlen(ch);
        int sum1=0,sum2=0;
        for(int i=0;i<len;i++)
        {
            if(ch[i]=='*')
                sum1++;
            else
                sum2++;
        }
        bool f=false;
        if(ch[len-1]=='*')
            f=true;
        int res=0;
        sum1++;
        int pas=0;
        if(sum1>sum2)
            res=sum1-sum2;
        else
            pas=sum2-sum1,f=true;
        int sum=res;
        if(f==false)
        {
            int i;
            for(i=0;i<len;i++)
                if(ch[i]=='*')
                    break;
            swap(ch[len-1],ch[i]);
            res++;
        }
        for(int i=0;i<len;i++)
        {
            if(ch[i]!='*')
                sum++;
            else
            {
                if(sum<2)
                {
                    res++;
                    if(pas>0)
                        pas--;
                    else
                    {
                        int j;
                        for(j=len-1;j>=0;j--)
                        {
                            if(ch[j]!='*')
                                break;
                        }
                        swap(ch[i],ch[j]);
                    }
                    sum++;
                }
                else
                    sum--;
            }
        }
        printf("%d\n",res);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值