HDU5024 2014 ACM-ICPC亚洲区域赛广州赛区网络赛C题 Wang Xifeng's Little Plot

Wang Xifeng's Little Plot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao's wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao. In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn't want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu's room and Baochai's room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai's room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu's room and Baochai's room. Now you can solve this big problem and then become a great redist.
 

Input
  
  
The map of Da Guan Yuan is represented by a matrix of characters '.' and '#'. A '.' stands for a part of road, and a '#' stands for other things which one cannot step onto. When standing on a '.', one can go to adjacent '.'s through 8 directions: north, north-west, west, south-west, south, south-east,east and north-east. There are several test cases. For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix. Then the N × N matrix follows. The input ends with N = 0.
 

Output
  
  
For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai's rooms. A road's length is the number of '.'s it includes. It's guaranteed that for any test case, the maximum length is at least 2.
 

Sample Input
  
  
3 #.# ##. ..# 3 ... ##. ..# 3 ... ### ..# 3 ... ##. ... 0
 

Sample Output
  
  
3 4 3
5

这道题算是这次广州赛区签到题,但是把我卡死,所以写博客留念此题,这题怎么看怎么都像BFS和DFS,坑了1个小时突然发现这个题其实可以用构造去搞,这题真的不是搜索啊,我和我的小伙伴都惊呆了,这题正确思路其实是一个构造矩阵过程,对于每一个位置,枚举可以往8个方向最多能走几步无法继续行走,然后对于每个位置,算出横竖位置总和和斜位置总和,最大的即为当前位置可以走的最远距离,然后对于每个点,求出最大的最远距离,即可AC,这个方法应该是O(n^3)的算法复杂度,但是还0msAC了,真的有点不能忍了。。。亏我搜索TLE了那么几发!!!

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<map>
#include<vector>
#include<queue>
using namespace std;
char ch[105][105];
int maxx=0,heng[105][105],shu[105][105],xie1[105][105],xie2[105][105];
int main()
{
//    freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        memset(heng,0,sizeof(heng));
        memset(shu,0,sizeof(shu));
        memset(xie1,0,sizeof(xie1));
        memset(xie2,0,sizeof(xie2));
        maxx=0;
        for(int i=0;i<n;i++)
            scanf("%s",ch[i]);
        int x=0,y=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(ch[i][j]=='.')
                {
                    if(heng[i][j]==0)
                    {
                        int pn=1,k=j+1;
                        while(k<n&&ch[i][k]=='.')
                        {
                            k++;
                            pn++;
                        }
                        for(int p=j;p<k;p++)
                            heng[i][p]=max(k-p,p-j+1);
                    }
                    if(shu[i][j]==0)
                    {
                        int pn=1,k=i+1;
                        while(k<n&&ch[k][j]=='.')
                        {
                            k++;
                            pn++;
                        }
                        for(int p=i;p<k;p++)
                            shu[p][j]=max(p-i+1,k-p);
                    }
                    if(xie1[i][j]==0)
                    {
                        int pn=1,k=i+1,p=j-1;
                        while(k<n&&p>=0&&ch[k][p]=='.')
                        {
                            k++;
                            p--;
                            pn++;
                        }
                        for(int x=i,y=j;x<k;x++,y--)
                            xie1[x][y]=maxxx(x-i+1,k-x);
                    }
                    if(xie2[i][j]==0)
                    {
                        int pn=1,k=i+1,p=j+1;
                        while(k<n&&p<n&&ch[k][p]=='.')
                        {
                            k++;
                            p++;
                            pn++;
                        }
                        for(int x=i,y=j;x<k;x++,y++)
                            xie2[x][y]=maxxx(x-i+1,k-x);
                    }
                }
            }
        }
        int maxx=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(heng[i][j]+shu[i][j]>maxx)
                    maxx=heng[i][j]+shu[i][j];
                if(xie1[i][j]+xie2[i][j]>maxx)
                    maxx=xie1[i][j]+xie2[i][j];
            }
        }
        cout<<maxx-1<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值