ZOJ 3829

Known Notation


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

 

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

 

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

题意:给你一个只包含数字和‘*’的串,有两种操作,插入数字或‘*’,交换两个字符的位置,问进行最少的操作个数将它变为一个合法的后缀表达式

首先判断是否足够,如果不够的话,就补上,应该补的数字个数应该是*的个数+1-数字的个数,因为最极限就是11*1*1*这种情况。然后我们把这些缺的数字全部放在串的最前面,从前往后遍历一遍,这时候要判断交换的条件,当*的数量+1-数字的数量大于0的时候应该执行交换,直接让这个*号与最右边的数字交换,然后*数量-1,数字数量+1,因为交换了,等于我们统计的这个东西变了。

还有一个坑点,11*234这种情况,网上大多数AC代码并没有判断这种情况都输出了0,但实际上这是不合法的后缀表达式,应该把*号与最后一个数字交换,特判一下即可

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1010;
char str[maxn];
int main()
{
	int test;
	scanf("%d",&test);
	while(test--)
	{
		scanf("%s",str);
		int len=strlen(str);
		int numa=0,numb=0;
		int pos=-1;
		for(int i=0;i<len;i++)
		{
			if(str[i]=='*')
			{
				numa++;
				if(pos==-1) pos=i;
			}
			else numb++;
		}
		if(numa==0)
		{
			printf("0\n");
			continue;
		}
		int ans=max(0,numa+1-numb);
		if(str[len-1]!='*')
		{
			swap(str[pos],str[len-1]);
			ans++;
		}
		numa=0;
		numb=max(0,numa+1-numb);
		for(int i=0;i<len;i++)
		{
			if(str[i]=='*') numa++;
			else numb++;
			if(numa+1-numb>0)
			{
				numa--;
				numb++;
				ans++;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值