Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
#include <iostream>
#include <cstring>
#include <cstdio>
#include<cmath>
#include <algorithm>
using namespace std;
int nn=1;
int star,end,f[100005],Max;
void solve()
{
int sum_star=1,sum=0; int flag=0;
star=end=1;Max=f[1];
for(int i=1;i<=f[0];i++)
{
if(f[i]>0) flag=1;
sum+=f[i];
if(sum>Max)
{
Max=sum; end=i;star=sum_star;
}
if(sum<0)
{
sum=0;
sum_star=i+1;
}
}
if(flag==0)
{ Max=f[1]; end=star=1;
for(int i=1;i<=f[0];i++)
if(Max<f[i])
{
Max=f[i];
end=star=i;
}
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&f[0]);
for(int i=1;i<=f[0];i++)
scanf("%d",&f[i]);
solve();
printf("Case %d:\n",nn++);
printf("%d %d %d\n",Max,star,end);
if(T)
printf("\n");
}
}