hdu 1077 Catching Fish

Catching Fish

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1076    Accepted Submission(s): 401


Problem Description
Ignatius likes catching fish very much. He has a fishnet whose shape is a circle of radius one. Now he is about to use his fishnet to catch fish. All the fish are in the lake, and we assume all the fish will not move when Ignatius catching them. Now Ignatius wants to know how many fish he can catch by using his fishnet once. We assume that the fish can be regard as a point. So now the problem is how many points can be enclosed by a circle of radius one.

Note: If a fish is just on the border of the fishnet, it is also caught by Ignatius.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a positive integer N(1<=N<=300) which indicate the number of fish in the lake. Then N lines follow. Each line contains two floating-point number X and Y (0.0<=X,Y<=10.0). You may assume no two fish will at the same point, and no two fish are closer than 0.0001, no two fish in a test case are approximately at a distance of 2.0. In other words, if the distance between the fish and the centre of the fishnet is smaller 1.0001, we say the fish is also caught.
 

Output
For each test case, you should output the maximum number of fish Ignatius can catch by using his fishnet once.
 

Sample Input
  
  
4 3 6.47634 7.69628 5.16828 4.79915 6.69533 6.20378 6 7.15296 4.08328 6.50827 2.69466 5.91219 3.86661 5.29853 4.16097 6.10838 3.46039 6.34060 2.41599 8 7.90650 4.01746 4.10998 4.18354 4.67289 4.01887 6.33885 4.28388 4.98106 3.82728 5.12379 5.16473 7.84664 4.67693 4.02776 3.87990 20 6.65128 5.47490 6.42743 6.26189 6.35864 4.61611 6.59020 4.54228 4.43967 5.70059 4.38226 5.70536 5.50755 6.18163 7.41971 6.13668 6.71936 3.04496 5.61832 4.23857 5.99424 4.29328 5.60961 4.32998 6.82242 5.79683 5.44693 3.82724 6.70906 3.65736 7.89087 5.68000 6.23300 4.59530 5.92401 4.92329 6.24168 3.81389 6.22671 3.62210
 

Sample Output
  
  
2 5 5 11
 

 

这题我刚开始用的两个点的中点作为圆心,后来发现连

样例也过不了,借鉴了大神的圆心的求法,终于过了。

题目大意:给你一个半径为1的圆,再给你n个点,

求这个圆最多覆盖n个点中的几个。

 

思路:枚举两个在圆上的点确定一个圆的圆心,

然后枚举出一共有多少点能被这个圆覆盖,求出其中最多的数目。

注意:要注意会用在圆上的两个点以及圆的半径求出圆心!

 

#include<iostream>
#include <cstdio>
#include<cstring>
#include<algorithm>
#include <cmath>
using namespace std;
 struct point
 {
     double x,y;
 };

 double dis(point a,point b)
   {
      return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
   }
point center(point a,point b)//求出圆心的位置
  {
      point s,e,m;
     s.x=b.x-a.x;
     s.y=b.y-a.y;
     m.x=(a.x+b.x)/2.0;
     m.y=(a.y+b.y)/2.0;
     double d=dis(a,m);
     double an=sqrt(1.0-d);
    if(fabs(s.y)<1e-8)
    {
        e.x=m.x;
        e.y=m.y+an;
    }
   else
    {
        double ang=atan(-s.x/s.y);//求该线段垂直平分线与x轴所形成的角
        e.x=m.x+an*cos(ang);
        e.y=m.y+an*sin(ang);
    }
   return e;
  }


int main()
{
   int T,n,i,j,k;
    point p[310],c;
   scanf("%d",&T);
  while(T--)
  {
    scanf("%d",&n);
   for(i=0;i<n;i++)
     scanf("%lf%lf",&p[i].x,&p[i].y);

   int ans=1;
   for(i=0;i<n-1;i++)
     for(j=i+1;j<n;j++)
   {
       if(dis(p[i],p[j])<=4.0)//枚举两个点
         {
              c=center(p[i],p[j]);

            int tmp=0;
          for(k=0;k<n;k++)
          {
             if(sqrt(dis(c,p[k]))<=1.000001)
                 tmp++;
          }
        if(ans<tmp) ans=tmp;
         }

   }
   printf("%d\n",ans);

  }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值