Nightmare


Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4 
1 0 0 0 1 0 0 1 
1 4 1 0 1 1 0 1 
1 0 0 0 0 3 0 1 
1 1 4 1 1 1 1 1 

Sample Output

4
-1
13
 
 
 
 
/*
    题意:给你一个N*M的矩阵,可以为0,1,2,3,4;0代表墙,1代表道路,2代表起点,3代表终点;
          4代表是爆炸装置置为0;
          规则:从起点到终点每走一步时间加1,遇到4,时间重新为0;
          求在6秒内能否走到终点。如果能输出走的步数,不能输出-1。
      
    解题报告:走过的路能够再走;
              走到4时,要把那个位置置标记,不能再走,否则会超时;
              一旦找到终点就结束。
*/
 
 
//标程:
 
 
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define maxn  1000000
struct ss
{
    int x,y,t;
};
struct sss
{
	int t,step;
}vis[100][100];


int n,m,xx,yy,flag;
int  s[100][100];
int dir[4][2]={0,1,1,0,-1,0,0,-1};
queue<ss> q;
void bfs()
{
    ss ans;
    int x1,x2,y1,y2,i;
    while(!q.empty())
    {
        ans=q.front();
        q.pop();
        x1=ans.x, y1=ans.y;
		vis[x1][y1].t=ans.t;
        for(i=0;i<4;i++)
        {
            x2=x1+dir[i][0], y2=y1+dir[i][1];
            if(x2>=0 && x2<n && y2>=0 && y2<m && s[x2][y2]!=0 && vis[x2][y2].step!=0 && vis[x1][y1].t>0)
            {
                if(s[x2][y2]==1 && vis[x2][y2].t+1<vis[x1][y1].t)
                {
                    vis[x2][y2].step=vis[x1][y1].step+1;
					vis[x2][y2].t=vis[x1][y1].t-1;
                    ans.x=x2, ans.y=y2, ans.t=vis[x2][y2].t;
                    q.push(ans);
                }
                if(s[x2][y2]==4)
                {
                    s[x2][y2]=0;
                    vis[x2][y2].t=5;
                    vis[x2][y2].step=vis[x1][y1].step+1;
                    ans.x=x2, ans.y=y2, ans.t=vis[x2][y2].t; 
                    q.push(ans);
                }
                if(s[x2][y2]==3  && vis[x1][y1].t>0)
                {
                    vis[x2][y2].step=vis[x1][y1].step+1;
					xx=x2, yy=y2;
					flag=1;
					return ;
                }
            }
        }
    }
}


int main()
{
    //freopen("a.txt","r",stdin);
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
		while(!q.empty()) q.pop();
		ss d;
        scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				vis[i][j].step=maxn;
				vis[i][j].t=0;
			}
        for(i=0;i<n;i++) 
		{
			for(j=0;j<m;j++)
			{
				scanf("%d",&s[i][j]);
				if(s[i][j]==2)
				{  
					d.x=i, d.y=j, d.t=5;
					q.push(d);
					vis[i][j].step=0;
				}
			}
		}
        flag=xx=yy=0;
        bfs();
        if(flag) printf("%d\n",vis[xx][yy].step);
        else printf("-1\n");
    }
    return 0;
}






 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值