A New Year Gift

Problem Description

Windbreaker was planning to send his friends some necklaces as New Year gifts. To show sincerity ,he decided to make the necklaces all by himself. He bought some kinds of pearls and each kind of pearls has a different color from others. He wanted to make each necklace consisted of M pearls from different kinds, that’s what he called M-perfect necklace. Windbreaker wanted to know the maximum number of necklaces he could send out to his friends. The number of pearls of each kind and M are given, and now you are asked to tell Windbreaker how many M-perfect necklaces he could make at most.

Input

You will be given a number of cases in the input. Each case starts with a positive integer n(n<=1000),which is the number of different kinds;
The second line contains n positive numbers represent for the number of pearls of each kind which will not exceed 2000.
The third line contains a positive number M(1<=M<=100).
The end of input is indicated by a line containing n=0.

Output

For each test case, output a line containing the Maximum number of M-perfect necklaces.

Sample Input

5
3 3 3 3 3
5
6
1 2 3 4 5 6
5
0

Sample Output

3
3
/*解题报告:所有的种类的珍珠总数为sum,项链的范围[1,sum];用二分查找,得到最大项链数。
            把所有种类能够构成项链的珍珠加起来,如果比mid*m种大,则符合条件,在从符合条件中
                 得到最大值。(初始值low=1, high=sum, mid=(low+high)/2);
*/
//标程:
#include<iostream>
#include<cstdio>
using namespace std;
int n,m;
int a[1010];
int judge(int x)
{
	int temp = 0;
	for(int i = 0; i < n; i ++)
	{
		if(x > a[i]) temp += a[i];
		else temp += x;
	}
	if(temp >= x*m) return 1;
	else return 0;
}
int main()
{
// 	freopen("a.txt","r",stdin);
    while(cin >> n, n)
	{
		int i, sum = 0;
		for(i = 0; i < n; i ++)
		{
			cin >> a[i];
			sum += a[i];
		}
		cin >> m;
        int low = 1, ans = 0;
		while(low <= sum)
		{
			int mid = (low+sum)/2;
			if(judge(mid))
			{
				ans = mid;
				low = mid + 1;
			}
			else 
				sum = mid - 1;
		}
		cout << ans << endl;
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值