UVA 1555 - Garland(推公式,贪心)

The New Year garland consists of N lamps attached to a common wire that hangs down on the ends to which outermost lamps are affixed. The wire sags under the weight of lamp in a particular way: each lamp is hanging at the height that is 1 millimeter lower than the average height of the two adjacent lamps.

The leftmost lamp in hanging at the height of A millimeters above the ground. You have to determine the lowest height B of the rightmost lamp so that no lamp in the garland lies on the ground though some of them may touch the ground.

You shall neglect the lamp's size in this problem. By numbering the lamps with integers from 1 to N and denoting the ith lamp height in millimeters as Hi we derive the following equations:

  • H1 = A
  • Hi = (Hi-1 + Hi+1)/2 - 1, for all 1 < i < N
  • HN = B
  • Hi ≥ 0, for all 1 ≤ i ≤ N

The sample garland with 8 lamps that is shown on the picture has A = 15 andB = 9.75.

Input 

The input file consists of several datasets. Each datasets contains a single line with two numbers N and Aseparated by a space. N (3 ≤ N ≤ 1000) is an integer representing the number of lamps in the garland, A(10 ≤ A ≤ 1000) is a real number representing the height of the leftmost lamp above the ground in millimeters.

Output 

For each dataset, write to the output the single real number B accurate to two digits to the right of the decimal point representing the lowest possible height of the rightmost lamp.

Sample Input 

692 532.81

Sample Output 

446113.34

题意:给定n和a,根据题目公式推出最小的B。

思路:推公式,H1 = a. H3 = H2*2 + 2 - H1, H4 = H3 * 2 + 2 - H2.....Hn = Hn - 1 * 2 + 2 - Hn - 2。 这样以H2做未知数。把系数K和B求出来。每个式子都是

K*H2 + B的形式。然后要求每个式子都大于0,H2尽量小。最后得到的Hn也将最小。

代码:

#include <stdio.h>
#include <string.h>

const int N = 1005;

int n, k[N];
double a, b[N], K;

double solve() {
	K = 0;
	k[1] = 0; b[1] = a; k[2] = 1; b[2] = 0.0;
	for (int i = 3; i <= n; i ++) {
		k[i] = 2 * k [i - 1] - k[i - 2];
		b[i] = 2 * b[i - 1] - b[i - 2] + 2;
		if (K * k[i] + b[i] < 0)
			K = -b[i] / k[i];
	}
	return K * k[n] + b[n];
}

int main() {
	while (~scanf("%d%lf", &n, &a)) {
		printf("%.2lf\n", solve());
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值