(转)数据结构实验之查找二:平衡二叉树

数据结构实验之查找二:平衡二叉树

Time Limit: 400 ms Memory Limit: 65536 KiB

Problem Description

根据给定的输入序列建立一棵平衡二叉树,求出建立的平衡二叉树的树根。

Input

输入一组测试数据。数据的第1行给出一个正整数N(n <= 20),N表示输入序列的元素个数;第2行给出N个正整数,按数据给定顺序建立平衡二叉树。

Output

输出平衡二叉树的树根。

Sample Input

5
88 70 61 96 120

Sample Output

70

(转)代码如下:(部分C++)

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
struct tree
{
    int data,h;
    tree*left,*right;
};
int heigh(tree*root)
{
    if(root==NULL)return 0;
    else return root->h;
}
tree*R_R(tree*root)
{
    tree*a=root,*b=root->right;
    a->right=b->left;
    b->left=a;
    a->h=max(heigh(a->left),heigh(a->right))+1;
    b->h=max(heigh(b->left),heigh(b->right))+1;
    return b;
}
tree*L_L(tree*root)
{
    tree*a=root,*b=root->left;
    a->left=b->right;
    b->right=a;
    a->h=max(heigh(a->left),heigh(a->right))+1;
    b->h=max(heigh(b->left),heigh(b->right))+1;
    return b;
}
tree*R_L(tree*root)
{
    tree*a=root,*b=root->right,*c=b->left;
    a->right=c->left;
    b->left=c->right;
    c->left=a;
    c->right=b;
    a->h=max(heigh(a->left),heigh(a->right))+1;
    b->h=max(heigh(b->left),heigh(b->right))+1;
    c->h=max(heigh(c->left),heigh(c->right))+1;
    return c;
}
tree*L_R(tree*root)
{
    tree*a=root,*b=root->left,*c=b->right;
    b->right=c->left;
    a->left=c->right;
    c->right=a;
    c->left=b;
    a->h=max(heigh(a->left),heigh(a->right))+1;
    b->h=max(heigh(b->left),heigh(b->right))+1;
    c->h=max(heigh(c->left),heigh(c->right))+1;
    return c;
}
tree*invert(tree*root,int x)
{
    if(root==NULL)
    {
        root=new tree;
        root->data=x;
        root->h=0;
        root->left=NULL;
        root->right=NULL;
    }
    else
    {
        if(x<root->data)
        {
            root->left=invert(root->left,x);
            if(heigh(root->left)-heigh(root->right)==2)
            {
                if(x<(root->left)->data)
                {
                    root=L_L(root);
                }
                else root=L_R(root);
            }
        }
        else
        {
            root->right=invert(root->right,x);
            if(heigh(root->left)-heigh(root->right)==-2)
            {
                if(x>(root->right)->data)
                {
                    root=R_R(root);
                }
                else root=R_L(root);
            }
        }
    }
    root->h=max(heigh(root->left),heigh(root->right))+1;
    return root;
}
int main()
{
    int n;
    tree*root;
    root=NULL;
    scanf("%d",&n);
    while(n--)
    {
        int x;
        scanf("%d",&x);
        root=invert(root,x);
    }
    printf("%d\n",root->data);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值