HDU 5280 Senior's Array

Senior’s Array

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 208 Accepted Submission(s): 83

Problem Description
One day, Xuejiejie gets an array A. Among all non-empty intervals of A, she wants to find the most beautiful one. She defines the beauty as the sum of the interval. The beauty of the interval—[L,R] is calculated by this formula : beauty(L,R) = A[L]+A[L+1]+……+A[R]. The most beautiful interval is the one with maximum beauty.

But as is known to all, Xuejiejie is used to pursuing perfection. She wants to get a more beautiful interval. So she asks Mini-Sun for help. Mini-Sun is a magician, but he is busy reviewing calculus. So he tells Xuejiejie that he can just help her change one value of the element of A to P . Xuejiejie plans to come to see him in tomorrow morning.

Unluckily, Xuejiejie oversleeps. Now up to you to help her make the decision which one should be changed(You must change one element).

Input
In the first line there is an integer T, indicates the number of test cases.

In each case, the first line contains two integers n and P. n means the number of elements of the array. P means the value Mini-Sun can change to.

The next line contains the original array.

1≤n≤1000, −109≤A[i],P≤109。

Output
For each test case, output one integer which means the most beautiful interval’s beauty after your change.

Sample Input
2
3 5
1 -1 2
3 -2
1 -1 2

Sample Output
8
2

Source
BestCoder Round #47 ($)
这里写图片描述

有一个O(n)时间计算 和最大连续区间的值 的模板。
需要注意的是这里MAXsum初始化不应该是0,应为存在一个数列全都是负数,应该初始化超级小的一个数。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <functional>
#include <numeric>
#include <sstream>
#include <stack>
#include <map>
#include <queue>
using namespace std;
int main()
{
    long long T;
    cin >> T;
    long long n,m; 
    while(cin >> n >> m)
    {
        long long num[1010];
        for(long long i=0;i<n;i++)
            cin >> num[i];
        long long maxn = -1000000000; 
        for(int j=0;j<n;j++)
        { 

        long long maxsum = -100000000,thissum = 0; 
        for(int i=0;i<n;i++)
        {
            if( i==j)thissum += m;
            else 
            thissum += num[i];
            if(thissum>maxsum)
            maxsum = thissum;
            else if(thissum<0)
            thissum = 0; 
        }
        maxn = max(maxsum,maxn); 
        } 
        cout<<maxn<<endl; 
    } 
    return 0;

} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值