Android关于Jenkins+Gradle自动化构建时Gradle版本冲突的问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u011153817/article/details/51971419

前言

   Jenkins自动化构建工具已经出来好久了,它为我们省去了不少的重复性工作,例如:构建,打包等。
但是对于初学者,刚开始的配置可能会有点麻烦。这里我就不再赘述了,不懂的童鞋请自行去找度娘。

正文

 今天在构建项目时,Jenkins构建失败,并报以下错误:

这里写图片描述

 意思就是项目里面配置的Gradle为2.10,但当前jenkins所用的版本为2.4,这个时候怎么办呢?
有两种方法:
一、把Jenkins服务器上的gradle版本2.4升级为2.10。
   但这个有个问题,如果这个Jenkins是全公司在用,那样升级后可能会引起其它项目因为gradle版本不一致而报错。因此还是慎用。

二、手动在Jenkins项目上进行配置。
   这种方法还是不错的,因为svn等仓库里面的代码所用gradle版本为2.10,那么我们就可以利用gradlew命令。那样,它会根据gradle-wrapper.properties里面的gradle版本来进行构建,如果没有,它会从服务器上下载。如果有,直接用现有的。如下:首先确保gradle/wrapper/gradle-wrapper.properties里面的版本为2.10
#Mon Dec 28 10:00:20 PST 2015
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip
然后再按下图配置Jenkins.

这里写图片描述

注意:上图的Invoke Gradle script 与Excute shell两者的位置是可以通过拖动来互换的,当然也可以通过下面的“增加构建步骤”来增加你自己的东西。其执行顺序就是从上到下。
最后点击保存或应用后,点击构建。
阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页