Ordering Tasks UVA10305

Problem F

Ordering Tasks

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

 

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and mn is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3

(The Joint Effort Contest, Problem setter: Rodrigo Malta Schmidt)


基本的拓扑排序,很简单。。但是我在边界条件卡了好久。。

#include<iostream>
#include<cstring>

using namespace std;

int grid[210][210];
int c[210],topo[210];
int n,m,t;

bool dfs(int u)
{
    c[u]=-1;
    for(int v=1;v<=n;v++)
    {
        if(grid[u][v])
        {
            if(c[v]<0) return false;
            else if(!c[v]&&!dfs(v)) return false;
        }
    }
    c[u]=1;
    topo[--t]=u;
    return true;
}

bool toposort()
{
    t=n;
    for(int u=1;u<=n;u++)
    {
        if(!c[u])
        {
            if(!dfs(u)) return false;
        }
    }
    return true;
}

int main()
{
    while(cin>>n>>m&&(n!=0||m!=0))
    {
        memset(grid,0,sizeof(grid));
        memset(c,0,sizeof(c));
        memset(topo,0,sizeof(topo));
        int x,y;
        while(m--)
        {
            cin>>x>>y;
            grid[x][y]=1;
        }
        toposort();
        cout<<topo[0];
        for(int i=1;i<n;i++)
            cout<<" "<<topo[i];
        cout<<endl;
    }
    return 0;
}

m可以等于0。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值