[贪心&&栈模拟]uva10700 Camel trading

Problem E - Camel trading

Time Limit: 1 second

Background

Aroud 800 A.D., El Mamum, Calif of Baghdad was presented the formula 1+2*3*4+5, which had its origin in the financial accounts of a camel transaction. The formula lacked parenthesis and was ambiguous. So, he decided to ask savants to provide him with a method to find which interpretation is the most advantageous for him, depending on whether is is buying or selling the camels.

The Problem

You are commissioned by El Mamum to write a program that determines the maximum and minimum possible interpretation of a parenthesis-less expression.

Input

The input consists of an integer N, followed by N lines, each containing an expression. Each expression is composed of at most 12 numbers, each ranging between 1 and 20, and separated by the sum and product operators + and *.

Output

For each given expression, the output will echo a line with the corresponding maximal and minimal interpretations, following the format given in the sample output.

Sample input

3
1+2*3*4+5
4*18+14+7*10
3+11+4*1*13*12*8+3*3+8

Sample output

The maximum and minimum are 81 and 30.
The maximum and minimum are 1560 and 156.
The maximum and minimum are 339768 and 5023.

题意:给你一个没有括号的表达式,只有数字和加乘号,怎么样组合使它最大最小?

思路:首先计算+号再计算乘号得到的结果最大,反之结果最小,可以用贪心方法处理,使用栈模拟,处理的时候遇到优先级大的先计算再压入栈中,最后处理优先级小的。

代码如下:

#include<iostream>
#include<stack>

using namespace std;

stack<long long>maxst;
stack<long long>minst;

int main()
{
    int num;
    cin>>num;
    while(num--)
    {
        while(!maxst.empty())
            maxst.pop();
        while(!minst.empty())
            minst.pop();
       long long val,x,y,z;
        char ch;
        cin>>val;
        maxst.push(val),minst.push(val);
        while(cin.get(ch)&&ch!='\n')
        {
            cin>>val;
            if(ch=='+')
            {
                x=maxst.top()+val;
                maxst.pop();
                maxst.push(x);
                minst.push(val);
            }
            else if(ch=='*')
            {
                x=minst.top()*val;
                minst.pop();
                minst.push(x);
                maxst.push(val);
            }
        }
        long long maxv=1,minv=0;
        while(!maxst.empty())
        {
            maxv=maxst.top()*maxv;
            maxst.pop();
        }
        while(!minst.empty())
        {
            minv=minst.top()+minv;
            minst.pop();
        }
        cout<<"The maximum and minimum are "<<maxv<<" and "<<minv<<"."<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值