Prime Ring Problem 搜索深度(简单回溯)

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Source

Asia 1996, Shanghai (Mainland China)

#include <iostream>
#include <stdio.h>    
using namespace std;

int rem[22];
int visit[22];
int n,flag,k;

bool prime(int x,int y)
{
 int sum=x+y;
 int i;
 for(i=2;i*i<=sum;i++)
  if(sum%i==0)
   return false;
  return true;
}

void dfs(int ans)
{
 int i;
 visit[1]=1;
   if(ans>n&&prime(rem[n],rem[1]))
   {
            if(!flag)
   {
    printf("Case %d:\n",k);
                  flag=1;
   }
   for(i=1;i<n;i++)
    printf("%d ",rem[i]);
   printf("%d\n",rem[i]);
   }
    else
 {
  for(i=2;i<=n;i++)
  {
   rem[ans]=i;
   if(!visit[i]&&prime(rem[ans],rem[ans-1]))
   {
    visit[i]=1;
    dfs(ans+1);
    visit[i]=0;
   }
  }
 }
}
int main()
{
  k=0;
 while(~scanf("%d",&n))
 {
  k++;
  memset(visit,0,sizeof(visit));
  rem[1]=1;
  flag=0;
  dfs(2);
  printf("\n");
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值