UVA 701 - The Archeologists' Dilemma(数论)

  The Archeologists' Dilemma 

An archeologist seeking proof of the presence of extraterrestrials in the Earth's past, stumbles upon a partially destroyed wall containing strange chains of numbers. The left-hand part of these lines of digits is always intact, but unfortunately the right-hand one is often lost by erosion of the stone. However, she notices that all the numbers with all its digits intact are powers of 2, so that the hypothesis that all of them are powers of 2 is obvious. To reinforce her belief, she selects a list of numbers on which it is apparent that the number of legible digits is strictly smaller than the number of lost ones, and asks you to find the smallest power of 2 (if any) whose first digits coincide with those of the list.

Thus you must write a program such that given an integer, it determines (if it exists) the smallest exponent E such that the first digits of 2Ecoincide with the integer (remember that more than half of the digits are missing).

Input 

It is a set of lines with a positive integer N not bigger than 2147483648 in each of them.

Output 

For every one of these integers a line containing the smallest positive integer E such that the first digits of 2E are precisely the digits of N, or, if there is no one, the sentence ``no power of 2".

Sample Input 

1
2
10

Sample Output 

7
8
20

题目大意:给出x,求一个e,使得x * 10 ^ y ≤ 2 ^ e < (x + 1) * 10 ^ y。 y要大于x的位数。

思路: 同取log2。 去枚举,

代码:

#include <stdio.h>
#include <string.h>
#include <math.h>

char X[15];
double x, y;

int main() {
    while (gets(X)) {
	sscanf(X, "%lf", &x);
	y = strlen(X) + 1;
	while (true) {
	    double f = log2(x) + y * log2(10);
	    double l = log2(x + 1) + y * log2(10);
	    if (ceil(f) - floor(l) <= 10e-9) {
		printf("%.0lf\n", ceil(f));
		break;
	    }
	    y ++;
	}
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值