UVa 701 The Archeologists' Dilemma (数学&枚举)

701 - The Archeologists' Dilemma

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=115&page=show_problem&problem=642

An archeologist seeking proof of the presence of extraterrestrials in the Earth's past, stumbles upon a partially destroyed wall containing strange chains of numbers. The left-hand part of these lines of digits is always intact, but unfortunately the right-hand one is often lost by erosion of the stone. However, she notices that all the numbers with all its digits intact are powers of 2, so that the hypothesis that all of them are powers of 2 is obvious. To reinforce her belief, she selects a list of numbers on which it is apparent that the number of legible digits is strictly smaller than the number of lost ones, and asks you to find the smallest power of 2 (if any) whose first digits coincide with those of the list.

Thus you must write a program such that given an integer, it determines (if it exists) the smallest exponentE such that the first digits of 2E coincide with the integer (remember that more than half of the digits are missing).

Input 

It is a set of lines with a positive integer N not bigger than 2147483648 in each of them.

Output 

For every one of these integers a line containing the smallest positive integer E such that the first digits of 2E are precisely the digits of N, or, if there is no one, the sentence ``no power of 2".

Sample Input 

1
2
10

Sample Output 

7
8
20

思路:


黑书上说这题可以用连分数逼近?没想出来...(坑)


完整代码:

/*0.023s*/

#include<cstdio>
#include<cmath>
const double log2_10 = log2(10.0);

int main(void)
{
	int n, m, i, tot, lower, upper;
	double t1, t2;
	while (~scanf("%d", &n))
	{
		t1 = log2(n), t2 = log2(n + 1);
		tot = 0;
		for (m = n; m; m /= 10)
			tot++;
		for (i = tot + 1;; ++i)
		{
			lower = (int)(t1 + i * log2_10);
			upper = (int)(t2 + i * log2_10);
			if (lower != upper)
			{
				printf("%d\n", upper);
				break;
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值