UVA 10417 - Gift Exchanging(概率 DFS)

Problem G
Gift Exchanging
Input:
 standard input
Output: standard output
Time Limit: 15 seconds
Memory Limit: 64 MB

You're attending a Xmas party, every one there (excepty you, I don't know why...) has brought a beautiful little gift in a box. After all the gifts are collected and laid on the table, every one can choose one to take home. You are the first one to choose, so there is a big chance for you to get the gift that is brought by your best friend :-)

Unfortunately, you cannot see inside the gift box, but luckily, there are only 5 possible kinds of boxes allowed in the party. We useA,B,C,D,E to represent these five kinds. You know well about all the guests there. i.e you know the probability that each person brings each kind of box. Which box should you take home, and what is the probability that you get the one you want?

Input

The first line of the input is a single integer t(1<=t<=10), indicating the number of test cases. Each case begins with a line containing a single integer n(1<=n<=12), indicating the number of guests. The second line of the case contains 5 integers indicating the number of gifts of each kind. The sum of these 5 numbers always equals to n. The following n lines each contain 5 non-negative floating numbers(with one digit after decimal point) indicating the probabilities for him to take box A,B,C,D,E. The sum of 5 numbers always equals to 1.0. The first guest is your best friend.

Output

For each test case, print a single character indicating the box you should choose, then a single space, then the probability to 3 decimal places. If there are more than one best choices, print the smallest box number.

Sample Input
2
2
1 0 0 1 0
0.5 0.0 0.0 0.5 0.0
0.4 0.0 0.5 0.1 0.0
8
1 3 2 1 1
0.1 0.2 0.3 0.2 0.2
0.0 0.8 0.2 0.0 0.0
0.3 0.0 0.1 0.6 0.0
0.0 0.9 0.1 0.0 0.0
0.2 0.2 0.0 0.3 0.3
0.2 0.1 0.6 0.1 0.0
0.7 0.2 0.1 0.0 0.0
0.1 0.0 0.0 0.2 0.7

Sample Output
4 0.800
3 0.296

题意:n个小伙伴每人准备了1个礼物, 第一行为组合出的情况res,后面n行为小伙伴送每种礼物的概率。要求出选那种礼物,拿到第一个小伙伴给的概率最高

思路:概率,以组合出res情况的概率做分母,然后枚举第一个小伙伴选每种礼物包含在其中的概率。 去进行深搜即可

代码:

#include <stdio.h>
#include <string.h>

int t, n, res[5];
double mu, zi[5], map[12][5];

void dfs(int num, double p, int j) {
    if (num == n) {
	zi[j] += p;
    }
    for (int i = 0; i < 5; i ++) {
	if (res[i] == 0) continue;
	res[i] --;
	dfs(num + 1, p * map[num][i], j);
	res[i] ++;
    }
}

int main() {
    scanf("%d", &t);
    while (t --) {
	memset(zi, 0, sizeof(zi));
	mu = 0;
	scanf("%d", &n);
	for (int i = 0; i < 5; i ++)
	    scanf("%d", &res[i]);
	for (int i = 0; i < n; i ++)
	    for (int j = 0; j < 5; j ++)
		scanf("%lf", &map[i][j]); 
	for (int i = 0; i < 5; i ++) {
	    if (res[i] == 0) continue;
	    res[i] --;
	    dfs(1, map[0][i], i);
	    res[i] ++;
	}
	for (int i = 0; i < 5; i ++)
	    mu += zi[i];
	double ans = 0; int v = 0;
	for (int i = 0; i < 5; i ++) {
	    if (res[i] == 0) continue;
	    if (ans < zi[i] / (mu * res[i])) {
		ans = zi[i] / (mu * res[i]);
		v = i + 1;
	    }
	}
	printf("%d %.3lf\n", v, ans);
	
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【优质项目推荐】 1、项目代码均经过严格本地测试,运行OK,确保功能稳定后才上传平台。可放心下载并立即投入使用,若遇到任何使用问题,随时欢迎私信反馈与沟通,博主会第一时间回复。 2、项目适用于计算机相关专业(如计科、信息安全、数据科学、人工智能、通信、物联网、自动化、电子信息等)的在校学生、专业教师,或企业员工,小白入门等都适用。 3、该项目不仅具有很高的学习借鉴价值,对于初学者来说,也是入门进阶的绝佳选择;当然也可以直接用于 毕设、课设、期末大作业或项目初期立项演示等。 3、开放创新:如果您有一定基础,且热爱探索钻研,可以在此代码基础上二次开发,进行修改、扩展,创造出属于自己的独特应用。 欢迎下载使用优质资源!欢迎借鉴使用,并欢迎学习交流,共同探索编程的无穷魅力! 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值