UVA 10417 - Gift Exchanging



Problem G
Gift Exchanging
Input:  standard input
Output:  standard output
Time Limit:  15 seconds
Memory Limit:  64 MB

You're attending a Xmas party, every one there (excepty you, I don't know why...) has brought a beautiful little gift in a box. After all the gifts are collected and laid on the table, every one can choose one to take home. You are the first one to choose, so there is a big chance for you to get the gift that is brought by your best friend :-)

Unfortunately, you cannot see inside the gift box, but luckily, there are only 5 possible kinds of boxes allowed in the party. We use A,B,C,D,E to represent these five kinds. You know well about all the guests there. i.e you know the probability that each person brings each kind of box. Which box should you take home, and what is the probability that you get the one you want?

Input

The first line of the input is a single integer t(1<=t<=10), indicating the number of test cases. Each case begins with a line containing a single integer n(1<=n<=12), indicating the number of guests. The second line of the case contains 5 integers indicating the number of gifts of each kind. The sum of these 5 numbers always equals to n. The following n lines each contain 5 non-negative floating numbers(with one digit after decimal point) indicating the probabilities for him to take box A,B,C,D,E. The sum of 5 numbers always equals to 1.0. The first guest is your best friend.

Output

For each test case, print a single character indicating the box you should choose, then a single space, then the probability to 3 decimal places. If there are more than one best choices, print the smallest box number.

Sample Input
2
2
1 0 0 1 0
0.5 0.0 0.0 0.5 0.0
0.4 0.0 0.5 0.1 0.0
8
1 3 2 1 1
0.1 0.2 0.3 0.2 0.2
0.0 0.8 0.2 0.0 0.0
0.3 0.0 0.1 0.6 0.0
0.0 0.9 0.1 0.0 0.0
0.2 0.2 0.0 0.3 0.3
0.2 0.1 0.6 0.1 0.0
0.7 0.2 0.1 0.0 0.0
0.1 0.0 0.0 0.2 0.7

Sample Output
4 0.800
3 0.296


The 2nd OIBH Online Programming Contest. Author: Rujia Liu


思路:直接搜就行了.....。


代码:

#include <iostream>
#include <string.h>
#include <cstdio>
#include <cstring>
#include <cassert>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <cmath>
#include <algorithm>
using namespace std;
#define rep(i,a,b) for(int i=(a);i<(int)(b);++i)
#define rrep(i,b,a) for(int i=(b);i>=(int)(a);--i)
#define clr(a,x) memset(a,x,sizeof(a))
#define ll long long
#define eps 1e-13
const int maxn = 12 + 5;
int n;
int rest[maxn];
int f[maxn][maxn];

inline int dcmp(double a,double b)
{
    if (a < b - eps) return -1;
    else if (a > b + eps) return 1;
    return 0;
}

void input()
{
    scanf("%d",&n);
    rep(i,0,5) scanf("%d",rest+i);
    rep(i,0,n) {
        rep(j,0,5)
            scanf("%*d.%d",&f[i][j]);
    }
}

ll ans[5], fenmu;
int gift[maxn];

void dfs(int cur, ll p)
{
    if (p == 0) return;
    if (cur == n) {
        if (gift[0] == 2)
            char a='a';
        ans[gift[0]] += p;
        fenmu += p;
        return;
    }
    rep(i,0,5) if (rest[i]) {
        gift[cur] = i;
        --rest[i];
        dfs(cur+1,p * f[cur][i]);
        ++rest[i];
    }
}

void solve()
{
    clr(gift,-1); clr(ans,0);
    fenmu = 0;
    dfs(0,1);
    int j = -1;
    rep(i,0,5) if (rest[i] && f[0][i]) {
        if (j == -1) j = i;
        else if (ans[j] / rest[j] < ans[i] / rest[i]) j = i;
    }
    if (j == -1 || fenmu == 0) printf("0 0.000\n");
    else printf("%d %.3f\n",j+1,(double)ans[j] / fenmu / rest[j]);
}

int main()
{
    #ifdef ACM
        freopen("in.txt","r",stdin);
    #endif
    int T; cin >> T;
    rep(cas,1,T+1) {
        input();
        solve();
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值