1442 - Cav(扫描+推理)

As an owner of a land with a cave you were delighted when you last heard that underground fuel tanks are great business. Of course, the more volume one can store, the better. In case of your cave, the efflective volume is not easy to calculate, because the cave has a rather sophisticated shape (see figure). Thank heavens it is degenerate in one dimension!

\epsfbox{p4621.eps}

The cave. All ponds that can be flooded with fuel are marked black.

Furthermore, there is some electrical wiring on the ceiling of the cave. You can never be sure if the insulation is intact, so you want to keep the fuel level just below the ceiling at every point. You can pump the fuel to whatever spots in the cave you choose, possibly creating several ponds. Bear in mind though that the fuel is a liquid, so it minimises its gravitational energy, e.g., it will run evenly in every direction on a flat horizontal surface, pour down whenever possible, obey the rule of communicating vessels, etc. As the cave is degenerate and you can make the space between the fuel level and the ceiling arbitrarily small, you actually want to calculate the maximum possible area of ponds that satisfy aforementioned rules.

Input 

The input contains several test cases. The first line of the input contains a positive integer  Z$ \le$15 , denoting the number of test cases. Then  Z  test cases follow, each conforming to the format described below


In the first line of an input instance, there is an integer n (1$ \le$n$ \le$106) denoting the width of the cave. The second line of input consists of n integers p1p2,..., pn and the third line consists of n integers s1,s2,..., sn, separated by single spaces. The numbers pi and si satisfy 0$ \le$pi < si$ \le$1000 and denote the floor and ceiling level at interval [ii + 1), respectively.

Output 

For each test case, your program has to write an output conforming to the format described below.


Your program is to print out one integer: the maximum total area of admissible ponds in the cave.

Sample Input 

1 
15 
6 6 7 5 5 5 5 5 5 1 1 3 3 2 2 
10 10 10 11 6 8 7 10 10 7 6 4 7 11 11

Sample Output 

14

题意:给定一个山洞,长度为n,然后每个位置有顶和底的高度,然后现在在里面存放油,油的最大高度不能没过顶,问最多能存多少油。

思路:既然不能没过顶,那么每个位置最大高度就是顶,那么对应顶的那条横线切过去,遇到比他高的就更新顶,遇到小的就替换用小的,然后从左往右再从右往左更新一遍,记录下每个位置的答案即可。

代码:

#include <stdio.h>
#include <string.h>
#define INF 0x3f3f3f3f
const int N = 1000005;

int t, n;
struct Cav {
	int floor, ceil;
}c[N];

void init() {
	scanf("%d", &n);
	int i;
	for (i = 0; i < n; i++)
		scanf("%d", &c[i].floor);
	for (i = 0; i < n; i++)
		scanf("%d", &c[i].ceil);
}

int solve() {
	int ans = 0, i, ceil = INF;
	for (i = n - 1; i >= 0; i--) {
		if (ceil < c[i].floor)
			ceil = c[i].floor;
		if (ceil > c[i].ceil)
			ceil = c[i].ceil;
		c[i].ceil = ceil;
	}
	ceil = INF;
	for (i = 0; i < n; i++) {
		if (ceil < c[i].floor)
			ceil = c[i].floor;
		if (ceil > c[i].ceil)
			ceil = c[i].ceil;
		c[i].ceil = ceil;
		ans += c[i].ceil - c[i].floor;
	}
	return ans;
}

int main() {
	scanf("%d", &t);
	while (t--) {
		init();
		printf("%d\n", solve());
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值