UVA 1424 - Salesmen(dp)

Traveling salesmen of nhn. (the prestigious Korean internet company) report their current location to the company on a regular basis. They also have to report their new location to the company if they are moving to another location. The company keep each salesman's working path on a map of his working area and uses this path information for the planning of the next work of the salesman. The map of a salesman's working area is represented as a connected and undirected graph, where vertices represent the possible locations of the salesman an edges correspond to the possible movements between locations. Therefore the salesman's working path can be denoted by a sequence of vertices in the graph. Since each salesman reports his position regularly an he can stay at some place for a very long time, the same vertices of the graph can appear consecutively in his working path. Let a salesman's working path be correct if two consecutive vertices correspond either the same vertex or two adjacent vertices in the graph.

For example on the following graph representing the working area of a salesman,

\epsfbox{p4256.eps}

a reported working path [1 2 2 6 5 5 5 7 4] is a correct path. But a reported working path [1 2 2 7 5 5 5 7 4] is not a correct path since there is no edge in the graph between vertices 2 a 7. If we assume that the salesman reports his location every time when he has to report his location (but possibly incorrectly), then the correct path could be [1 2 2 4 5 5 5 7 4], [1 2 4 7 5 5 5 7 4], or [1 2 2 6 5 5 5 7 4].

The length of a working path is the number of vertices in the path. We define the distance between two pathsA = a1a2...an and B = b1b2...bn of the same length n as

dist( AB) =  $\displaystyle \sum^{​{n}}_{​{i=1}}$ d ( a ib i)

where

d ( ab) =  $\displaystyle \left\{\vphantom{ \begin{array}{cc} 0 & \mbox{if } a=b \\  1 & \mbox{otherwise} \end{array} }\right.$ $\displaystyle \begin{array}{cc} 0 & \mbox{if } a=b \\  1 & \mbox{otherwise} \end{array}$

Given a graph representing the working area of a salesman and a working path (possible not a correct path),A , of a salesman, write a program to compute a correct working path, B , of the same length where the distance dist(AB) is minimized.

Input 

The program is to read the input from standard input. The input consists of T test cases. The number of test cases (T) is given in the first line of the input. The first line of each test case contains two integers n1n2 (3$ \le$n1$ \le$100, 2$ \le$n2$ \le$4, 950) where n1 is the number of vertices of the graph representing the working map of a salesman and n2 is the number of edges in the graph. The input graph is a connected graph. Each vertex of the graph is numbered from 1 to n1 . In the following n2 lines, each line contains a pair of vertices which represent an edge of the graph. The last line of each test case contains information on a working path of the salesman. The first integer n (2$ \le$n$ \le$200) in the line is the length of the path and the following n integers represent the sequence of vertices in the working path.

Output 

Your program is to write to standard output. Print one line for each test case. The line should contain the minimum distance of the input path to a correct path of the same length.

Sample Input 

2 
7 9 
1 2 
2 3 
2 4 
2 6 
3 4 
4 5 
5 6 
7 4 
7 5 
9 1 2 2 7 5 5 5 7 4 
7 9 
1 2 
2 3 
2 4 
2 6 
3 4 
4 5 
5 6 
7 4 
7 5 
9 1 2 2 6 5 5 5 7 4

Sample Output 

1 
0

题意:给一个n个点的无向图,和一个序列L,问最少需要几次修改使得L串的相邻两个数都相同或者对应图中两个相邻结点。

思路:dp,dp[i][j]表示状态为长度i最后一个数字为j的情况需要的最少修改次数。那么状态转移方程很好推出为:dp[i][k] = min(dp[i][k], dp[i - 1][j] + (l[i] != k))

j表示最后一个数字的前一个字符,k表示当前最后一个数字。

代码:

#include <stdio.h>
#include <string.h>
#define min(a,b) ((a)<(b)?(a):(b))
#define INF 0x3f3f3f3f
const int N = 105;

int t, n, m, g[N][N], l[2 * N], dp[2 * N][N];

int solve() {
	int ans = INF;
	for (int i = 1; i <= m; i++) {
		for (int jj = 1; jj <= n; jj++)
			dp[i][jj] = INF;
		for (int j = 1; j <= n; j++) {
			for (int k = 1; k <= n; k++) {
				if (g[j][k])
					dp[i][k] = min(dp[i][k], dp[i - 1][j] + (l[i] != k));
				if (i == m) ans = min(ans, dp[i][k]);
			}
		}
	}
	return ans;
}

int main() {
	scanf("%d", &t);
	while (t--) {
		memset(g, 0, sizeof(g));
		scanf("%d%d", &n, &m);
		int x, y;
		while (m--) {
			scanf("%d%d", &x, &y);
			g[x][y] = g[y][x] = 1;
		}
		scanf("%d", &m);
		for (int i = 1; i <= m; i ++)
			scanf("%d", &l[i]);
		for (int j = 1; j <= n; j++)
			g[j][j] = 1;
		printf("%d\n", solve());
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值