hdu 1010 Tempter of the Bone(dfs+奇偶剪枝)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52416    Accepted Submission(s): 14094


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

Sample Output
  
  
NO YES

Author
ZHANG, Zheng

Source

Recommend
JGShining
 
题意:一个迷宫,有门,但只能在t时刻打开。问人能不能走出去。能输出"YES",反之输出"NO".
分析:如果不加剪枝,a^n的复杂度,一定超时。加奇偶剪枝优化。
代码:
//输入不能用gets()。会WA!
//discuss上说是字符可能全在一行,不一定是矩阵。但是题目分明说n lines...这不科学!
//gets()不是可以吃掉回车么。
//scanf("%s",c);接受字符是以空格或者制表符或者回车分隔的,不会接受回车
//gets(),是以为回车分隔的

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define N 10
using namespace std;

char maps[N][N];
int dx[4]={-1,1,0,0};
int dy[4]={0,0,-1,1};
int flag,r,c,sx,sy,ex,ey,t;

void dfs(int x,int y,int step)
{
    int tmp=t-step-abs(ex-x)-abs(ey-y);
	//printf("%d\n",tmp);
    if(tmp<0||tmp%2) return;
    for(int i=0;i<4;i++)
    {
        int tx,ty;
        tx=x+dx[i];
        ty=y+dy[i];
		//printf("%d %d\n",tx,ty);
        if(maps[tx][ty]=='D'&&step==t-1)
        {
            flag=1;
            return;
        }
        if(maps[tx][ty]=='.'&&tx>=1&&tx<=r&&ty>=1&&ty<=c)
        {
            maps[tx][ty]='X';    //标记访问
            dfs(tx,ty,step+1);
            maps[tx][ty]='.';     //回溯取消标记
            if(flag==1) return;   //找到直接返回
        }
    }
}

int main()
{
    int i,j,step;
    while(scanf("%d%d%d",&r,&c,&t)&&r&&c&&t)
    {
		getchar();
        for(i=1;i<=r;i++)
        {
			//scanf("%s",maps[i]+1);      //写法2(比1慢一点)
			//gets(maps[i]+1);       //不能这么写,会wa!
            for(j=1;j<=c;j++)
            {
				scanf("%c",&maps[i][j]);  //写法1
				if(maps[i][j]=='S')
                {
                    sx=i;
                    sy=j;
                }
                if(maps[i][j]=='D')
                {
                    ex=i;
                    ey=j;
                }
            }
			getchar();    //注意要加上!
        }
        flag=0;
        step=0;
        dfs(sx,sy,step);
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


/*

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

*/

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值