线段树之poj 2777

Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30727 Accepted: 9174

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

题意

       两种操作,一是将A到B区间内的颜色全部染成C颜色,另外就是查询A至B区间内有多少种颜色。A B大小关系不确定。(这道题当时用线段树提交上去后居然超时了,瞬间傻眼,后来才发现是h数组开大了,所有颜色种类不超过30,而我开个100000,杯具啊。。。)

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

struct node{
    int left,right,mid,color;
}tree[400010];
int  h[31];

void build(int le,int ri,int num)
{
    int ls,rs;
    ls=num<<1;rs=num<<1|1;
    tree[num].left=le;
    tree[num].right=ri;
    tree[num].mid=(le+ri)>>1;
    tree[num].color=1; //  开始时都为涂有颜色1
    if(le==ri)
        return ;
    build(le,tree[num].mid,ls);
    build(tree[num].mid+1,ri,rs);
}

void change(int le,int ri,int num,int col)
{
    int ls=num<<1,rs=num<<1|1;
    if(tree[num].left==le&&tree[num].right==ri)
    {
        tree[num].color=col;
        return ;
    }
    if(tree[num].color==col)   // 这个剪枝还优40多MS,效果还蛮不错的。
        return;
//    printf("cha%d %d\n",num,tree[num].color);
    if(tree[num].color)
    {
        tree[ls].color = tree[num].color;
        tree[rs].color = tree[num].color;
        tree[num].color = 0;
    }
    if(ri<=tree[num].mid)
        change(le,ri,ls,col);
    else if(le>tree[num].mid)
        change(le,ri,rs,col);
    else
    {
        change(le,tree[num].mid,ls,col);
        change(tree[num].mid+1,ri,rs,col);
    }
}

void sove(int le,int ri,int num)
{
    int ls=num<<1,rs=num<<1|1;
    if(tree[num].color)
    {
        h[tree[num].color]=1;
        return;
    }
 //   printf("sov%d %d\n",num,h[tree[num].color]);
    if(ri<=tree[num].mid)
        sove(le,ri,ls);
    else if(le>tree[num].mid)
        sove(le,ri,rs);
    else
    {
        sove(le,tree[num].mid,ls);
        sove(tree[num].mid+1,ri,rs);
    }
}

int main()
{
    int L,T,O,i,j,le,ri,col,sum;
    char z;
    scanf("%d %d %d",&L,&T,&O);
        getchar();
        build(1,L,1);
        memset(h,0,sizeof(h));
        for(i=0;i<O;i++)
        {
            scanf("%c %d %d",&z,&le,&ri);
            getchar();//防止将换行符存入z中
            if(z=='C')
            {
                scanf("%d",&col);
                getchar();//同上
                if(le<=ri)  
                   change(le,ri,1,col);
                else
                    change(ri,le,1,col);

             }
             else
             {
                if(le<=ri)
                    sove(le,ri,1);
                else
                    sove(ri,le,1);
                for(j=1,sum=0;j<=T;j++)
                    sum += h[j];
                 printf("%d\n",sum);
                 memset(h,0,sizeof(h));//此处一定要注意清零
             }
        }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值