单调队列之最大最小成员

 


poj2823_Sliding WindowCrawling in process...

Crawling failed

Time Limit:12000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u       

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:        
The array is [1 3 -1 -3 5 3 6 7], and k is 3.       
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.        

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.        

Sample Input

8 3
1 3 -1 -3 5 3 6 7

 

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Hint

题意:

       给你一个长度不超过10 6 的数组,有一个长度为k的滑动窗口从数组的最左边依次移动到最右边,找出每次移动后整个窗口里面的最大值和最小值

解析:

     这是一道典型的单调队列,先给它用降序排一次,队列的第一个数就是每次移动后的最大值,同理,升序排一次可以得到最小值。不过这道题有点坑,不能用G++提交,因为那样必须超时,但换成C++就能过(李博学长解释是由于C++用的是WINDOWS的编译器,对输入输出有优化的,但是G++没有优化。)

 

 

#include<iostream>
#include<cstdio>
using namespace std;

int w[1000006],q[1000006],p[1000006];
int dow[1000006],up[1000006],p1,p2,q1,q2;

int main()
{
    int n,k,minx,i;
    scanf("%d %d",&n,&k);
    p1=p2=q1=q2=1;
    for(i=1;i<=n;i++)
    {
        scanf("%d",&w[i]);
        while(p1<p2&&w[i]<=w[p[p2-1]])//形成一个单调递增队列
           p2--;//w[p[p1]]最小
        p[p2++]=i;//入队
        while(q1<q2&&w[i]>=w[q[q2-1]])//形成一个单调递减数列,注意是q2-1
            q2--;
        q[q2++]=i;//q2-1的原因
        if(i-p[p1]>=k) p1++;
        if(i-q[q1]>=k) q1++;
        if(i>=k)
        {
            dow[i]=w[p[p1]];
            up[i]=w[q[q1]];
            printf("%d ",dow[i]);
        }
    }
    //for(i=k;i<n;i++)
       // printf("%d ",dow[i]);
    printf("\n");
    for(i=k;i<n;i++)
        printf("%d ",up[i]);
    printf("%d\n",up[i]);
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值