NYOJ 题目58 最少步数 (简单BFS)

最少步数

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述

这有一个迷宫,有0~8行和0~8列:

 1,1,1,1,1,1,1,1,1
 1,0,0,1,0,0,1,0,1
 1,0,0,1,1,0,0,0,1
 1,0,1,0,1,1,0,1,1
 1,0,0,0,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,0,0,0,1
 1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

输入
第一行输入一个整数n(0<n<=100),表示有n组测试数据;
随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出
输出最少走几步。
样例输入
2
3 1  5 7
3 1  6 7
样例输出
12
11

简单BFS,,,,


/***************************
# 2013-8-30 13:38:53 
# Time: 4MS   Memory:308K
# Author: zyh
# Status: Accepted
***************************/ 

#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

struct point{
	int x,y,step;
};
bool Map[9][9]={
 1,1,1,1,1,1,1,1,1,
 1,0,0,1,0,0,1,0,1,
 1,0,0,1,1,0,0,0,1,
 1,0,1,0,1,1,0,1,1,
 1,0,0,0,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,0,0,0,1,
 1,1,1,1,1,1,1,1,1};

int dir[4][2]={1,0,-1,0,0,1,0,-1};
int c,d;

void bfs(int x,int y){	
	queue<point>q;
	bool vis[9][9];
	memset(vis,0,sizeof(vis));
	point p,tmp;	
	
	p.x=x; p.y=y; p.step = 0;
	
	q.push(p);
	cnt =0;
		
	while(!q.empty()){	
		p = q.front(); q.pop();
		vis[p.x][p.y] = 1;
		if(p.x==c && p.y==d) {	
			printf("%d\n",p.step);
			return;
		}
		for(int i=0;i<4;i++){
			tmp.x = p.x+dir[i][0];
			tmp.y = p.y+dir[i][1];
			tmp.step = p.step +1;
			if(tmp.x>8||tmp.x<0 || tmp.y>8||tmp.y<0) continue;			
			if(Map[tmp.x][tmp.y]==0 && !vis[tmp.x][tmp.y]) q.push(tmp);
		}
	}

}
int main()
{
	int n,a,b;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d%d%d",&a,&b,&c,&d);
		bfs(a,b);
	}
	return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值