02-线性结构2. 一元多项式求导 (25)


时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard

设计函数求一元多项式的导数。(注:xn(n为整数)的一阶导数为n*xn-1。)

输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是0,但是表示为“0 0”。

输入样例:
3 4 -5 2 6 1 -2 0
输出样例:
12 3 -10 1 6 0
#include <iostream>
#include <malloc.h>
#include <stdio.h>
#include <stdlib.h>
using namespace std;

typedef struct node
{
    int a,b;
    struct node *next;
}List,*LinkList;

LinkList creatLinkList()
{
    LinkList L;
    L=(List*)malloc(sizeof(List));
    return L;
}

void initLinkList(LinkList &L)
{
    List *p,*q=L;
    while(1)
    {
        p=(List*)malloc(sizeof(List));
        cin>>p->a;
        char ch;
        ch=getchar();
        cin>>p->b;
        ch=getchar();
        //cout<<p->a<<" "<<p->b<<endl;
        p->next=NULL;
        q->next=p;
        q=p;
        if(ch=='\n')
            break;
    }
}

void result(LinkList &L)
{
    List *p=L->next;
    while(p)
    {
        p->a=p->a*p->b;
        p->b--;
        p=p->next;

    }
}

void display(LinkList L)
{
    List *p=L->next;
    if(p->b==-1)
        {
            cout<<"0 0\n";
            return ;
        }
    while(p)
    {

        if(((p->next!=NULL)&&(p->next->a==0))||p->next==NULL)
        {
            cout<<p->a<<" "<<p->b<<endl;
            break;
        }else
            cout<<p->a<<" "<<p->b<<" ";
        p=p->next;
    }

}

int main()
{
    LinkList L;
    L=creatLinkList();
    initLinkList(L);

    if(L->next->a==0&&L->next->b==0)
        cout<<"0 0\n";
    else
    {
        result(L);
        display(L);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值