04-树7. Search in a Binary Search Tree (25)


时间限制
100 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

To search a key in a binary search tree, we start from the root and move all the way down, choosing branches according to the comparison results of the keys. The searching path corresponds to a sequence of keys. For example, following {1, 4, 2, 3} we can find 3 from a binary search tree with 1 as its root. But {2, 4, 1, 3} is not such a path since 1 is in the right subtree of the root 2, which breaks the rule for a binary search tree. Now given a sequence of keys, you are supposed to tell whether or not it indeed correspnds to a searching path in a binary search tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (<=100) which are the total number of sequences, and the size of each sequence, respectively. Then N lines follow, each gives a sequence of keys. It is assumed that the keys are numbered from 1 to M.

Output Specification:

For each sequence, print in a line "YES" if the sequence does correspnd to a searching path in a binary search tree, or "NO" if not.

Sample Input:
3 4
1 4 2 3
2 4 1 3
3 2 4 1
Sample Output:
YES
NO
NO
#include <iostream>
#include <string.h>
#define N 101

using namespace std;

int main()
{
    int a[N],n,m,i,j,flag,k;
    cin>>n>>m;
    for(i=0;i<n;i++)
    {
        memset(a,-1,sizeof(N));
        for(j=0;j<m;j++)
            cin>>a[j];
        flag = a[0];
        bool result = true;
        for(j=1;j<m;j++)
        {

            if(flag<a[j])
            {
                for(k=j+1;k<m;k++)
                    if(flag > a[k])
                    {
                        result = false;
                        break;
                    }

            }else if(flag>a[j])
            {
                for(k=j+1;k<m;k++)
                    if(flag < a[k])
                    {
                        result = false;
                        break;
                    }
            }
            if(!result)
            {
                cout<<"NO\n";
                break;
            }else
                flag = a[j];
        }
        if(result)
            cout<<"YES\n";

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值