C - A Simple Problem with Integers

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

/*经典的区间更新和查询问题
  这里注意会爆int,
  区间查询时的懒标记不好理解
*/ 
#include <iostream>
#include<cstdio>
#include<algorithm>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ll long long 
using namespace std;
const int maxn = 1e5+4;
ll sum[maxn<<2],add[maxn<<2];//sum为区间和,add为懒标记 
void push_up(int rt)//向父节点传递 
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void push_down(int rt,int m)//向儿子结点传递, 
{
	if(add[rt])
	{
		add[rt<<1]+=add[rt];//更新左儿子 
		sum[rt<<1] +=(m-(m>>1))*add[rt];
		add[rt<<1|1]+=add[rt];//更新右儿子 
		sum[rt<<1|1] +=(m>>1)*add[rt];
		add[rt]=0; //清楚父节点的标记 
	}
}
void build(int l,int r,int rt)
{
	add[rt]=0;
	if(l==r)
	{
		scanf("%lld",&sum[rt]);
		return ;
	}
	int m = (l+r)/2;
	build(lson);
	build(rson);
	push_up(rt);
}
ll query(int L,int R,int l,int r,int rt)
{
	if(L<=l&&r<=R)
		return sum[rt];
	int m = (l+r)/2;
	ll ans = 0;
	push_down(rt,r-l+1);
	if(L<=m) ans+=query(L,R,lson);
	if(R>m) ans+=query(L,R,rson);
	return ans; 
}
void update(int L,int R,int c,int l,int r,int rt)
{
	if(L<=l&&r<=R)//如果区间已被完全包含,停止更新, 
	{
		add[rt]+=c;
		sum[rt]+=(r-l+1)*1ll*c;
		return ;
	}
	push_down(rt,r-l+1);//有标记时往下更新 
	int m = (l+r)/2;
	if(L<=m) update(L,R,c,lson);
	if(R>m) update(L,R,c,rson);
	push_up(rt);
}
int main(int argc, char** argv) {
	int n,q;
	scanf("%d %d",&n,&q);
	build(1,n,1);
	while(q--)
	{
		char ch[2];
		scanf("%s",ch);
		if(ch[0]=='Q') 
		{
			int a,b;
		    scanf("%d %d",&a,&b);
		    printf("%lld\n",query(a,b,1,n,1));	
		}
		else if(ch[0]=='C')
		{
			int a,b,c;
			scanf("%d %d %d",&a,&b,&c);
			update(a,b,c,1,n,1);
		}
	}
	return 0;
}

 下面给出树状数组的写法

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#define PI atan(1.0) * 4
#define e 2.718281828
#define rp(i, s, t) for (i = (s); i <= (t); i++)
#define RP(i, s, t) for (i = (t); i >= (s); i--)
#define ll long long
#define ull unsigned long long
#define mst(a, b) memset(a, b, sizeof(a))
#define push_back() pb()
#define fastIn                    \
    ios_base::sync_with_stdio(0); \
    cin.tie(0);
using namespace std;
inline int read()
{
    int a = 0, b = 1;
    char c = getchar();
    while (c < '0' || c > '9')
    {
        if (c == '-')
            b = -1;
        c = getchar();
    }
    while (c >= '0' && c <= '9')
    {
        a = (a << 3) + (a << 1) + c - '0';
        c = getchar();
    }
    return a * b;
}
inline void write(int n)
{
    if (n < 0)
    {
        putchar('-');
        n = -n;
    }
    if (n >= 10)
        write(n / 10);
    putchar(n % 10 + '0');
}
int n;
const int N = 1e5 + 7;
ll sum1[N], sum2[N];
ll a[N];
void add(ll p, ll x)
{
    for (int i = p; i <= n; i += i & -i)
        sum1[i] += x, sum2[i] += x * p;
}
void range_add(ll l, ll r, ll x)
{
    add(l, x), add(r + 1, -x);
}
ll query(ll p)
{
    ll res = 0;
    for (int i = p; i; i -= i & -i)
    {
        res += (p + 1) * sum1[i] - sum2[i];
    }
    return res;
}
ll range_query(ll l, ll r)
{
    return query(r) - query(l - 1);
}
int main()
{
    n = read();
    int q = read(), i;
    a[0]=0;
    rp(i, 1, n)
    {
        a[i] = read();
        int x=a[i]-a[i-1];
        add(i,x);
    }
    while (q--)
    {
        char opt[10];
        int l, r, delta;
        scanf("%s", opt);
        if (opt[0] == 'Q')
        {
            l = read(), r = read();
            printf("%lld\n",range_query(l,r));
        }
        else
        {
            l = read(), r = read(), delta = read();
            range_add(l, r, delta);
        }
    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值