Bone Collector解题报告

题目摘要:Many years ago , in Teddy’shometown there was a man who was called “Bone Collector”. This man like tocollect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip ofcollecting there are a lot of bones , obviously , different bone has differentvalue and different volume, now given the each bone’s value along his trip ,can you calculate out the maximum of the total value the bone collector can get?

题目大意:很多年以前,有个人爱收集骨头,狗的骨头,牛的骨头……现在他有个体积为V的包,在他的旅途中,他可以将遇到的骨头放进包里,每个骨头有两个属性,一个是体积,一个是价值,求他能得到的最大价值

输入输出要求

Input

The first line contain a integer T , thenumber of cases.
Followed by T cases , each case three lines , the first line contain twointeger N , V, (N <= 1000 , V <= 1000 )representing the number of bonesand the volume of his bag. And the second line contain N integers representingthe value of each bone. The third line contain N integers representing thevolume of each bone.

 

Output

One integer per line representing themaximum of the total value (this number will be less than 231).

 

输入输出样例

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

 

Sample Output

14

解题思路:完全是01背包问题,代码都一样……

代码

#include<iostream>

#include<cmath> 

using namespace std; 

int f[1005]; 

int w[1005],c[1005];

int max(int a,int b)

{

       if(a>b)

              return a;

       return b;

int main() 

    int i,j,n,v,t; 

    cin>>t; 

    while(t--) 

   

      cin>>n>>v; 

      memset(f,0,sizeof(f)); 

      for(i=1;i<=n;i++) 

        cin>>w[i]; 

      for(i=1;i<=n;i++) 

        cin>>c[i]; 

      for(i=1;i<=n;i++) 

     

        for(j=v;j>=c[i];j--) 

       

            f[j]=max(f[j],f[j-c[i]]+w[i]); 

       

      

      cout<<f[v]<<endl; 

   

    return 0; 

}

解题感想:模板题不解释

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值