DP训练~Bone Collector(入门)~解题报告

Bone Collector

题目描述:

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input:

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output:

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input:

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output:

14

题目大意:

现在给你一个T(测试样例子),以及N(骨头数量)与V(背包的容量),接下来会分别输出N个骨头价值以及N个骨头体积,分别一一对应,接下来题目要求你如何能将背包装满并且还要获得骨头价值最大。

思路分析:

这个问题就是01背包的衍生,每根骨头只能装一个,并不能重复装,那么问题可以简化成,该不该拿这个骨头,如果拿了以及不拿那个价值大,就采取那种方式,那么我们有二维数组记录背包里的种类以及背包的容量则有,dp[i][j]=max(dp[i-1][j]+dp[i-1][j-v[i]]+n[i]),v[i]与n[i]分别代表骨头的体积与价值。
这里解释一下数组中元素意义与原理:i代表背包中的种类,j代表背包的容量。

  1. 这里讲一下我们装骨头一般会挑价值最大(体积最小的),那么我们可以这样思考,假设背包容量从0开始增加,那么假设只能装一种骨头,那么就考虑拿不拿问题,用上述dp[i][j]=max(dp[i-1][j]+dp[i-1][j-v[i]]+n[i])
  2. 随着种类的变多,我们公式也就一直在类推下去,知道dp[i][j]的行元素与列元素取到最大值时,说明这里的值已经是最大,这就是我们要找的价值最大,背包容量恰好。

代码:

#include<iostream>
#include<cstdio>
#include<map>
#include<stack>
#include<vector>
#include<queue>
#include<algorithm>
#include<string.h>
#define ms(a,b) memset((a),(b),sizeof((a)))
using namespace std;
int v[1005];
int n[1005];
int dp[1005][1005];
void LemonDP(int N,int V)
{
	for(int i=1;i<=N;i++)
	{
		for(int j=0;j<=V;j++)
		{
			if(j>=v[i])
			{
				dp[i][j]=max(dp[i-1][j],dp[i-1][j-v[i]]+n[i]);
			}
			else
			{
				dp[i][j]=dp[i-1][j];
			}
		}
	}
	cout << dp[N][V] << endl;
}
int main()
{
	int N,V,t;
	cin >> t;
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		cin >> N >> V;
		for(int i=1;i<=N;i++)
		{
			scanf("%d",&n[i]);
		}
		for(int i=1;i<=N;i++)
		{
			scanf("%d",&v[i]);
		}
		LemonDP(N,V);
	}
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值