Eming

问题 A : Eming
题目描述
Eming is a contest hold by WHUACM training team. The aim is to select new members of the team. 
Usually, the first problem is a very simple problem such as “a+b problem”. But this time, Xioumu is tired of this kind of problem, he decide to solve “a and b problem”.
Give you the result of a + b and a^2 – b^2, please output the result of a and b.
输入格式
There are several test cases. For each case there are two double numbers indicating a+b and a^2-b^2. You may assume that a+b will not be zero.
输出
For each case please output the result of a and b in one line, rounded to 2 decimal places.
样例输入
3 -3
样例输出
1.00 2.00

#include<stdio.h>

int main()
{
double x,y,m;
double a,b;
while(scanf("%lf%lf",&x,&y)!=EOF)
{
m=(y/x);
a=(x+m)/2;
b=(x-m)/2;
printf("%.2lf %.2lf\n",a,b);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七刀

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值