我的第一次编程

1.题目描述

Beinga nonconformist, Volodya is displeased with the current state of things,particularly with the order of natural numbers (natural number is positiveinteger number). He is determined to rearrange them. But there are too manynatural numbers, so Volodya decided to start with the first n. He writes downthe following sequence of numbers: firstly all odd integers from 1 to n (inascending order), then all even

integersfrom 1 to n (also in ascending order). Help our hero to find out which numberwill stand at the position number k.

Input

Theonly line of input contains integers n and k (1≤k≤n≤1e14).  

Output

Printthe number that will stand at the position number k after Volodya'smanipulations.  

Sampletest(s) input
10 3

77

output

5

6

Note

In thefirst sample Volodya's sequence will look like this: {1, 3, 5, 7, 9, 2, 4, 6,8, 10}. The third place in the sequence is therefore occupied by the number 5.

Hint

注意数据的类型

use__int64 to read data and use %I64d to output data 

输入格式

The onlyline of input contains integers n and k (1≤k≤n≤1e14).  

输出

Printthe number that will stand at the position number k after Volodya'smanipulations.  

样例输入

10 3
7 7

样例输出

5
6

代码如下:

 

 

#include<iostream>

using namespace std;

 

int main(void)

{

         longlong n,k;

         while(cin>>n>>k)

         {

                   longlong Result=0;

                   if(n%2==0)

                   {

                            if(k<=n/2)

                            {

                                     Result=2*k-1;

                            }

                            else

                            {

                                     Result=2*k-n;

                            }

                            cout<<Result<<endl;

                   }

                   else

                   {

                            if(k<=n/2+1)

                            {

                                     Result=2*k-1;

                            }

                            else

                            {

                                     Result=2*k-n-1;

                            }

                            cout<<Result<<endl;

                   }

         }

         return0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值