A+B for Input-Output Practice (IV)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49610 Accepted Submission(s): 26566
Problem Description
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
4 1 2 3 4 5 1 2 3 4 5 0
Sample Output
10 15
求许多整数相加的和,当遇到0是,输出结束。
发现自己出了一点小小的错误,没有考虑到n=0的情况;
我的代码如下:
#include<iostream>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
if(n==0)
return 0;
int sum=0;
while(n--)
{
int a;
cin>>a;
sum=sum+a;
}
cout<<sum<<endl;
}
return 0;
}