题目1154:Jungle Roads

题目描述:

   

    The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

输入:

    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

输出:

    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

样例输入:
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
样例输出:
216
30

代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
int tree[27];
int findRoot(int x) {
    if(tree[x] == -1) return x;
    else {
	int tmp = findRoot(tree[x]);
	tree[x] = tmp;
	return tmp;
    }
}

struct Edge {
    int s;
    int e;
    int d;
}edge[80];

bool cmp(Edge A,Edge B) {
    return A.d < B.d;
}

int main() {
    int n;
    while(scanf("%d",&n)!=EOF) {
	if(n==0)
	    break;
	char c1,c2;
	int m;
	int size = 0; 
	for(int i=1;i<n;i++) {
	    scanf(" %c %d",&c1,&m);
	    //printf("c1= %c,m=%d\n",c1,m);
	    for(int j=0;j<m;j++) {
		scanf(" %c %d",&c2,&edge[size].d);
		//printf("c2=%c, d=%d\n",c2,edge[size].d);
		int s = c1 - 'A' + 1;
		int e = c2 - 'A' + 1;
		//printf("c1= %c, c2=%c\n",c1,c2);
		edge[size].s = s;
		edge[size].e = e;
		size++;
		//printf("s:%d e:%d\n",edge[size].s,edge[size].e);
	    }
	}
	sort(edge,edge+size,cmp);
	int sum = 0;
	for(int i=1;i<=n;i++)
	    tree[i] = -1;
	for(int i=0;i<size;i++) {
	    int a = findRoot(edge[i].s);
	    int b = findRoot(edge[i].e);
	    if(a != b) {
		tree[a] = b;
		sum += edge[i].d;
	    }
	}
	printf("%d\n",sum);
    }
    return 0;
}



编写过程中出现如下几个错误:
1.scanf函数。

#include <stdio.h>
int main() {
    int m,n;
    char x,y;
    scanf("%c %d",&x,&m);
    printf("x=%c m=%d\n",x,m);
    while(m--) {
	scanf("%c %d",&y,&n);
	printf("%c %d\n",y,n);
    }
    return 0;
}
运行后出现如下结果,与预测的运行结果不同。

把第九行改为: printf("%d %d\n",y,n);

可以发现y的值输出为10,10对应的为\n,即换行符!因为我们输入 A 3 (enter) ,就将enter保存到下一个scanf语句中了,即B中。

解决方法:

①将第八行改为: scanf(" %c %d",&y,&n);  //在%c前面加一个空格

scanf在格式控制串加了空白字符(包括空格,回车,制表符等),会使scanf在读操作的过程中略去一个或多个空白字符。

②使用fflush(stdin)

清空键盘缓冲器中的信息。


2.在代码中加入了fflush(stding),提交OJ后,runtime error。

解决方法:删去该句!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值