uva 529 Addition Chains(迭代深搜)

737 篇文章 0 订阅
232 篇文章 0 订阅

  Addition Chains 

An addition chain for n is an integer sequence $<a_0, a_1, a_2, \dots, a_m>$ with the following four properties:

  • a0 = 1
  • am = n
  • a0<a1<a2<...<am-1<am
  • For each k ( $1 \le k \le m$) there exist two (not neccessarily different) integers i and j ( $0 \le i, j \le k-1$) with ak =ai +aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.

For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing one integer  n  (  $1 \le n \le 10000$ ). Input is terminated by a value of zero (0) for  n .

Output Specification 

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.


Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.

Sample Input 

5
7
12
15
77
0

Sample Output 

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77
题目大意:给出一个数n,要求找出一个集合,集合的末尾数必须为n,并且集合中的任意一个数必须可以用集合中另外两个数组成,找出集合数最小的,并输出。

解题思路:迭代深搜的方法,先确定数的基数,就是说组成这个数最少需要几个数,例如1个数最大组成1, 2个数最大组成2, 而3个数最大为4(每增加一个数,最大值 * 2)

一个很重要的剪枝,当当前第i个数,为k, k的在剩余的位数中以倍数形式增长后任小于目标值。

#include <stdio.h>
#include <string.h>
#define N 20
int order, num[N], ok;

void DFS(int cur, int sum){
    if (cur >= sum + 1){
	if (num[sum] == order){
	    ok = 1;
	    return ;
	}
    }
    else{
	if (num[cur - 1] << sum - cur + 1 < order)
	    return;
	for (int i = cur - 1; i >= 0; i--)
	    for (int j = cur - 1; j >= 0; j--){
		num[cur] = num[i] + num[j];
		DFS(cur + 1, sum);
		if (ok) return ;
	    }
    }
}

int main(){
    while (scanf("%d", &order), order){
	int k, n;
	ok = 0;
	for (k = 0; ; k++)
	    if (1 << k >= order)
		break;

	for (n = k; ; n++){
	    memset(num, 0, sizeof(num));
	    num[1] = 1;
	    DFS(2, n);
	    if (ok) break;
	}

	for (int i = 1; i < n; i++)
	    printf("%d ", num[i]);
	printf("%d\n", num[n]);
    }
    return 0;}

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值