uva 529 - Addition Chains


  Addition Chains 

An addition chain for n is an integer sequence $<a_0, a_1, a_2, \dots, a_m>$ with the following four properties:

  • a0 = 1
  • am = n
  • a0<a1<a2<...<am-1<am
  • For each k ( $1 \le k \le m$) there exist two (not neccessarily different) integers i and j ( $0 \le i, j \le k-1$) with ak =ai +aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.

For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing one integer n ( $1 \le n \le 10000$). Input is terminated by a value of zero (0) for n.

Output Specification 

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.


Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.

Sample Input 

5
7
12
15
77
0

Sample Output 

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77
迭代加深dfs很适合n=10000,17个数字,虽然感觉上迭代本身存在大量重复计算,但是重复的搜索树的深度小;
迭代加深搜索算法就是仿广度优先搜索的深度优先搜索。既能满足深度优先搜索的线性存储要求,又能保证发现一个最小深度的目标结点。
#include <string.h>
#include <stdio.h>
int a[100],best[100],n,min,f;
int minlen(int num,int len)
{int x=num,y=len;
 while (x<n) {x=x<<1;++y;}
 return y;
}
void dfs(int len)
{
 int i,j,time,x;
 if ((a[len]==n)&&(len<min)) {f=0; min=len; for (i=1;i<=len;i++) best[i]=a[i]; }
 if ((a[len]>=n)||(len>=min)) return ;
 if (minlen(a[len],len)>=min) return ;
 for (i=1;i<=len;i++)
 for (j=i;j<=len;j++)
 {
  a[len+1]=a[i]+a[j];
  if (a[len+1]>a[len]) dfs(len+1);
 }
}
int main()
{
 int i;
 a[1]=1; a[2]=2;
 best[1]=1; best[2]=2;
 while (scanf("%d",&n),n)
 {
  f=1; min=minlen(2,2)-1;
  if (n<=2) {min=n;f=0;}
  while (f)
  {++min;
   dfs(2);
  }
  for (i=1;i<min;i++)
     printf("%d ",best[i]);
  printf("%d\n",n);
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值