FZU - 2039 Pets (二分图匹配 2011年全国大学生程序设计邀请赛(福州))

Description

Are you interested in pets? There is a very famous pets shop in the center of the ACM city. There are totally m pets in the shop, numbered from 1 to m. One day, there are n customers in the shop, which are numbered from 1 to n. In order to sell pets to as more customers as possible, each customer is just allowed to buy at most one pet. Now, your task is to help the manager to sell as more pets as possible. Every customer would not buy the pets he/she is not interested in it, and every customer would like to buy one pet that he/she is interested in if possible.

Input

There is a single integer T in the first line of the test data indicating that there are T(T≤100) test cases. In the first line of each test case, there are three numbers n, m(0≤n,m≤100) and e(0≤e≤n*m). Here, n and m represent the number of customers and the number of pets respectively.

In the following e lines of each test case, there are two integers x(1≤x≤n), y(1≤y≤m) indicating that customer x is not interested in pet y, such that x would not buy y.

Output

For each test case, print a line containing the test case number (beginning with 1) and the maximum number of pets that can be sold out.

Sample Input

1
2 2 2
1 2
2 1

Sample Output

Case 1: 2

Source

2011年全国大学生程序设计邀请赛(福州)
题意:有n个人分别对应不喜欢某个宠物,问最多能卖出去几只
思路:简单的二分图匹配,匈牙利算法模板
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int MAXN = 110;

int g[MAXN][MAXN], vis[MAXN];
int lined[MAXN];
int n, m, e;

int dfs(int u) {
	for (int v = 1; v <= m; v++) {
		if (g[u][v] && !vis[v]) {
			vis[v] = 1;
			if (lined[v] == -1 || dfs(lined[v])) {
				lined[v] = u;
				return 1;
			}
		}
	}
	return 0;
}

int main() {
	int t, cas = 1;;
	scanf("%d", &t);
	while (t--) {
		memset(g, 1, sizeof(g));
		memset(lined, -1, sizeof(lined));
		scanf("%d%d%d", &n, &m, &e);
		for (int i = 0; i < e; i++) {
			int a, b;
			scanf("%d%d", &a, &b);
			g[a][b] = 0;
		}
		int ans = 0;
		for (int i = 1; i <= n; i++) {
			memset(vis, 0, sizeof(vis));
			if (dfs(i))
				ans++;
		}
		printf("Case %d: ", cas++);
		printf("%d\n", ans);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值