UVA - 1494 Qin Shi Huang's National Road System (类次小生成树)

Description

Download as PDF

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China -- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty-- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor " in Chinese.

\epsfbox{p5713.eps}

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national roadsystem. There is a story about the road system:

There were n cities in China and Qin Shi Huang wanted them all be connected byn - 1 roads, in order that he could go to every city from the capital city Xianyang. Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the roadsystem may not cost too many people's life. A daoshi(some kind of monk) named Xu Fu told Qin Shi Huangthat he could build a road by magic and that magic roadwould cost no money and no labor. But Xu Fu couldonly build ONE magic road for Qin Shi Huang. So QinShi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible -- So Qin Shi Huang decided that the value ofA/B (theratio of A toB) must be the maximum, which A is the total population of the two cites connected by the magic road, andB is the total length of none magic roads.

Would you help Qin Shi Huang?

A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input

The first line contains an integer t meaning that there aret test cases (t$ \le$10).

For each test case:

The first line is an integer n meaning that there aren cities (2 < n$ \le$1000).

Then n lines follow. Each line contains three integersX, Y and P (0$ \le$X,Y$ \le$1000, 0 <P < 100000). (X, Y) is the coordinate of a city andP is the population of that city.

It is guaranteed that each city has a distinct location.

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

Sample Output

65.00
70.00

题意:有n个城市,要修路使得两两城市互通,可以修一条任意的路不用花费,现设B是总长度,A是不用花费就能修的两个城市的人口总数,求最大的A/B的方案,两个城市的距离是欧几里得距离

思路:求出最小生成树的同时记录最小生成树中任意两个点之间唯一路径的最大权的边的值,这个只要在要更新树的时候,在已经生成的树中更新就行了

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
using namespace std;
const int maxn = 1005;
const int inf = 0x3f3f3f3f;

struct City {
	int x, y, num;
};

struct MST {
	double d[maxn];
	double dist[maxn][maxn];
	double maxcost[maxn][maxn];
	int done[maxn];
	int fa[maxn];

	void init() {
		memset(maxcost, 0, sizeof(maxcost));
		memset(done, 0, sizeof(done));
	}

	double Prime(int n) {
		double ans = 0;
		for (int i = 0; i < n; i++)
			d[i] = inf;
		d[0] = 0;
		fa[0] = 0;
		for (int j = 0; j < n; j++) {
			int k;
			double Min = inf;
			for (int i = 0; i < n; i++)
				if (!done[i] && d[i] < Min)
					Min = d[k = i];
			ans += dist[fa[k]][k];
			for (int i = 0; i < n; i++)
				if (done[i])
					maxcost[k][i] = maxcost[i][k] = max(maxcost[fa[k]][i],
							dist[fa[k]][k]);
			done[k] = 1;
			for (int i = 0; i < n; i++)
				if (!done[i] && d[i] > dist[k][i]) {
					d[i] = dist[k][i];
					fa[i] = k;
				}
		}
		return ans;
	}
};
MST solve;
City city[maxn];
int n;

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		solve.init();
		for (int i = 0; i < n; i++)
			scanf("%d%d%d", &city[i].x, &city[i].y, &city[i].num);
		for (int i = 0; i < n-1; i++)
			for (int j = i+1; j < n; j++) {
				int nx = city[i].x - city[j].x;
				int ny = city[i].y - city[j].y;
				double tmp = sqrt((double)nx*nx+ny*ny);
				solve.dist[i][j] = solve.dist[j][i] = tmp;
			}
		double cost, Max = 0;
		cost = solve.Prime(n);
		for (int i = 0; i < n-1; i++) 
			for (int j = i+1; j < n; j++) {
				double tmp = cost - solve.maxcost[i][j];
				int num = city[i].num + city[j].num;
				if (Max < num/tmp)
					Max = num/tmp;
			}
		printf("%.2f\n", Max);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值