HDU - 2256 Problem of Precision

Description


 

Input

The first line of input gives the number of cases, T. T test cases follow, each on a separate line. Each test case contains one positive integer n. (1 <= n <= 10^9)
 

Output

For each input case, you should output the answer in one line.
 

Sample Input

    
    
3 1 2 5
 

Sample Output

  
  
9 97 841

题意:求式子的值

思路:借鉴GG 的一张图


#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
typedef long long ll;
using namespace std;
const int mod = 1024;
const int maxn = 2;

struct Matrix {
	ll v[maxn][maxn];
	Matrix() {}
	Matrix(int x) {
		init();	
		for (int i = 0; i < maxn; i++)
			v[i][i] = x;
	}
	void init() {
		memset(v, 0, sizeof(v));
	}
	Matrix operator *(Matrix const &b) const {
		Matrix c;
		c.init();
		for (int i = 0; i < maxn; i++)
			for (int j = 0; j < maxn; j++)
				for (int k = 0; k < maxn; k++)
					c.v[i][j] = (c.v[i][j] + (v[i][k]*b.v[k][j])%mod) % mod;
		return c;
	}
	Matrix operator ^(int b) {
		Matrix a = *this, res(1);
		while (b) {
			if (b & 1)
				res = res*a;
			a = a*a;
			b >>= 1;
		}
		return res;
	}
} A;

int main() {
	int t, n;
	scanf("%d", &t);
	Matrix cnt;
	cnt.v[0][0] = 5, cnt.v[0][1] = 12, cnt.v[1][0] = 2, cnt.v[1][1] = 5;
	while (t--) {
		scanf("%d", &n);	
		Matrix tmp = cnt^(n-1); 
		int ans = (2*(5 * tmp.v[0][0] + 2 * tmp.v[0][1])-1) % mod;
		printf("%d\n", ans);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值